1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tranny problem

Discussion in 'Other Vehicle Discussions' started by Think, Jul 15, 2004.

  1. Think

    Think Senior Member

    Messages:
    166
    Likes Received:
    0
    Joined:
    Sep 21, 2003
    Location:
    Missouri
    Ok, i have a 99 grand am GT, after driving for id say about 20 mins or so, when i go to take off (in first) the tranny seems to be slipping. Such as it will hit about 2.5k rpm and then go into first, same thing as into 2nd as well. Car has about 86k miles on it. Any help would be greatful. thanks
     
  2. ssl2k

    ssl2k Senior Member

    Messages:
    191
    Likes Received:
    0
    Joined:
    Mar 8, 2004
    replace your clutch

    nuff said
     
  3. TurboMirage

    TurboMirage YEEAAAHHH VIP

    Messages:
    24,582
    Likes Received:
    697
    Joined:
    May 20, 2003
    Location:
    Central, MA
    i think hes got an auto.

    get your tranny fluid replaced, or get it filled.
     
  4. Think

    Think Senior Member

    Messages:
    166
    Likes Received:
    0
    Joined:
    Sep 21, 2003
    Location:
    Missouri
    it is auto, and it only seems to be doing it, after i put the car in reverse and then into drive while still rolling a little bit. Not that a big of a deal to stop, but just curious. Thanks
     
  5. hybrid89

    hybrid89 thistownsucks...

    Messages:
    1,821
    Likes Received:
    1
    Joined:
    Jan 8, 2003
    Location:
    SoCal
    low transmission fluid.
    hole in one of the rubber lines on the transmisiion housing
    tarnny is taking a shit!

    these are my thoughts....

    matt
     
Verification:
Draft saved Draft deleted

Share This Page