1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Turbo h22 integra prob

Discussion in 'General Tech and Maintenance' started by illicit_kustomz, Apr 25, 2007.

  1. illicit_kustomz

    illicit_kustomz Junior Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    May 4, 2004
    I just finished installing my t3/t4 turbo on my h22 swap today i start the car and it wont idle and when i go to accelerate heavily it backfires like crazy. Im not running any mods except a chipped ecu eliminating o2 sensor and egr valve. Do you think i need a bigger fuel pump and injectors or what. Im only boosting 5 pounds.
     
  2. streetrays

    streetrays Member

    Messages:
    148
    Likes Received:
    0
    Joined:
    Aug 21, 2003
    Location:
    ATX
    you won't need fuel pump or injectors yet. i don't think so. the ecu or other place in the setup is still not right. ignition? injector wiring? maps?
     
  3. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    make sure theres not a boost leak
     
  4. powerdriverh22

    powerdriverh22 Senior Member

    Messages:
    825
    Likes Received:
    2
    Joined:
    Jul 21, 2005
    Location:
    spfld, mo
    what are you tuning the car with.....if you say an fmu....you need to be hit over the head. sounds like you have some timing issues...among other things, put up your set up, and how you are tuning it
     
  5. Turbo&Auto

    Turbo&Auto Nick Go FAST!!

    Messages:
    3,269
    Likes Received:
    29
    Joined:
    Jan 9, 2006
    Location:
    East Burg, PA!
    Did you add boost tools to the map in your chip? Are you waiting till the car warms up fully??? Send your map to nick@nicksturbomatrix.com and I can look over it quick for you.
     
  6. illicit_kustomz

    illicit_kustomz Junior Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    May 4, 2004
    im still running a stock map. No im not using a fmu. New chip for boost is on its way. Eveyrthing on the h22 is stock except the chipped ecu. Im using a brand new t3/t4 xs power setup...
     
  7. Turbo&Auto

    Turbo&Auto Nick Go FAST!!

    Messages:
    3,269
    Likes Received:
    29
    Joined:
    Jan 9, 2006
    Location:
    East Burg, PA!
    Thats the problem. What chip are you getting???

    xs ftl
     
  8. illicit_kustomz

    illicit_kustomz Junior Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    May 4, 2004
    All I know is it's chipped by CROME... Got a walbro 255 and some blue tops today.
     
Verification:
Draft saved Draft deleted

Share This Page