1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Turbo help

Discussion in 'HYBRID -> ED-EF / DA' started by DayOh257, Mar 15, 2004.

  1. DayOh257

    DayOh257 Junior Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Mar 13, 2004
    I swapped an 89 B16A SiR1 into my 88 Hatch. Then boosted it with a home-made turbo to 7 lbs.

    Problem is I get the "check engine" light and the car hiccups - smooth running then a hard jerk before resuming - under acceleration and occassionally during cruise. I have just installed a missing link MAP bypass, which eliminated most of the hiccups, but they still occur and it's quite annoying.

    Other than the turbo, the engine and car are both stock and unchanged.

    Any suggestions?
     
  2. brian11to1

    brian11to1 Senior Member

    Messages:
    9,203
    Likes Received:
    21
    Joined:
    Jan 9, 2003
    Let me be the first to say, this is in the incorrect forum. This goes into the Forced Induction Forum. I wish I could help you, however I know absolutely nothing about Turbo's!
     
  3. DayOh257

    DayOh257 Junior Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Mar 13, 2004
    Oh, sorry. Perhaps one of the mods can send this thread to the right place.

    Thanks!
     
  4. Jim Truett

    Jim Truett Senior Member

    Messages:
    114
    Likes Received:
    0
    Joined:
    Jul 11, 2003

    Chip your ECU to read boost and get rid of the missing link.

    PGMFI
     
  5. DayOh257

    DayOh257 Junior Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Mar 13, 2004


    OK, call me ignorant, but uh.... how do you do that?? :huh:
     
  6. Jim Truett

    Jim Truett Senior Member

    Messages:
    114
    Likes Received:
    0
    Joined:
    Jul 11, 2003


    All of the information can be found in my sig. Look to pgmfi.org for the tools and techniques.
     
Verification:
Draft saved Draft deleted

Share This Page