1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

USB 2.0 support

Discussion in 'Computers, Games, Electronics etc' started by xj0hnx, Oct 27, 2005.

  1. xj0hnx

    xj0hnx I wanna be sedated VIP

    Messages:
    14,172
    Likes Received:
    48
    Joined:
    Nov 10, 2002
    Location:
    C.C.TX.
    Ok, so I put Windows back on, but the legit copy I have is one of the first to come out before the service packs. I tried to install my USB 2.0 external HD, and got a message saying it could perform faster in a 2.0 port. Now, I have 2.0 ports, all the ones on my mobo support it. So I try to use the 2.0 driver for my mobo and it tells me that with service pack 2 (I updated, duh) it is not nescessary to install these drivers. Well, apparently something didn't click when I updated and they are not being supported to the fullest.

    Anyone have any idea what I can do here? I have tried finding the drivers in the system32 and they are there, but when I try to update manually it won't choose them.
     
  2. Citizen_Insane

    Citizen_Insane Senior Member

    Messages:
    3,698
    Likes Received:
    3
    Joined:
    Jul 24, 2003
    Location:
    Minneapolis
    try going into the device manager and finding the USB hardware and tell it to reinstall the drivers.
     
  3. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    yeah, remove them from device manager.
    re-boot
    let windows re-install the hardware on boot up which should load the newer driver
     
  4. xj0hnx

    xj0hnx I wanna be sedated VIP

    Messages:
    14,172
    Likes Received:
    48
    Joined:
    Nov 10, 2002
    Location:
    C.C.TX.
    Didn't work :cry2:
     
  5. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    are you sure is a usb2 board? lol
     
  6. TurboMirage

    TurboMirage YEEAAAHHH VIP

    Messages:
    24,577
    Likes Received:
    696
    Joined:
    May 20, 2003
    Location:
    Central, MA
    build 2600 doesnt support usb2. you need atleast SP1 to install any usb2 driver.

    try uninstalling them again, then delete your mobo usb2 drivers from add/remove (mine were in there), or the actual driver files, then use the generic windows ones.

    dont forget to check windowsupdate for hardware update, or you mobo manufacturer website.
     
  7. xj0hnx

    xj0hnx I wanna be sedated VIP

    Messages:
    14,172
    Likes Received:
    48
    Joined:
    Nov 10, 2002
    Location:
    C.C.TX.
    Looks like it had something to do with going straight to SP2 I guess....

     
Verification:
Draft saved Draft deleted

Share This Page