1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ut oh.. my CRX started running funky this morning :(

Discussion in 'Civic and CRX - EF' started by dacheat, Mar 10, 2010.

  1. dacheat

    dacheat ..is grounded.

    Messages:
    4,216
    Likes Received:
    205
    Joined:
    Jul 7, 2007
    Location:
    strongbadia
    background:

    stock d15b2 with 270k miles on it. recently done timing belt, spark plugs, distributor.

    been running fine w/no issues. started fine, ran fine for about 5 miles through stop-n-go traffic, and then i noticed a sluggish, gurgling/rumbly loss of power when accelerating from a stoplight. no smoke in the rear view that i could see. temp gauge was fine too. did detect a slight roughness to my idle, though still idling at 800rpm.

    the last 2 miles in to work were me hoping it would just keep rolling til i got to the parking lot - which it did...

    had a meeting so didn't have time for much - checked under the car for leaks (none) and popped the hood to see if anything looked amiss (no).

    kinda scared to start it up after work. :eek:

    i'll check the fluids before i start the car again, and i'll check for codes on the ECU (my CEL doesn't work, i'm thinking). i don't have any tools with (they're in the other rex right now), so not sure i can get into my dizzy to check the rotor screw unless i can score some tools here at work.

    any other ideas for me to check on, meanwhile?
     
    Last edited: Mar 10, 2010
  2. 95b16coupe

    95b16coupe New Member

    Messages:
    6,538
    Likes Received:
    224
    Joined:
    Nov 6, 2008
    Location:
    ct
    with that specific work being done recently, check the timing. it's cheap and easy to do.
     
  3. dacheat

    dacheat ..is grounded.

    Messages:
    4,216
    Likes Received:
    205
    Joined:
    Jul 7, 2007
    Location:
    strongbadia
    Ok..what would cause it to change/occur mid-commute like that? just curious..
     
  4. 95b16coupe

    95b16coupe New Member

    Messages:
    6,538
    Likes Received:
    224
    Joined:
    Nov 6, 2008
    Location:
    ct
    test it out. if it bogs then surges, i'm 90% positive it's timing. something might not have been tightened all the way or they could have just done a bad job with the timing belt.

    it could possibly be a clogged exhaust or bad cat. when it got warmed it, it shit out on you.

    check all your plugs, wires, dizzy and make sure they are tight and have good contact. then check your timing, check the exhaust last.
     
  5. dacheat

    dacheat ..is grounded.

    Messages:
    4,216
    Likes Received:
    205
    Joined:
    Jul 7, 2007
    Location:
    strongbadia
    update - went out between meetings to confirm the fluids seem fine, and no leak under the car. it started fine, and about 2 seconds into running, it started missing/hesitating..audibly, visually (tach), and you could feel it from the seat.

    checked quick for ECU codes and wasn't (but really was) disappointed. didn't have much time. looks like either 15 or 16.

    15- Accord Civic CRV CRX Del Sol Odyssey Prelude
    90-95 88-95 n/a 88-91 93-95 95 88-95
    Ignition Output Signal
    missing or defective ignition output signal

    16- Accord Civic CRV CRX Del Sol Odyssey Prelude
    90-95 88-95 n/a 88-91 93-95 95 88-95
    Fuel Injector System
    defective circuit or unplugged / defective fuel injector

    next check looks like ignitor and injectors; i think they were kinda coming due anyway. bleh.
     
  6. 95b16coupe

    95b16coupe New Member

    Messages:
    6,538
    Likes Received:
    224
    Joined:
    Nov 6, 2008
    Location:
    ct
    check all the connections first. pull the plugs out and make sure they aren't messed up or covered in oil or anything.

    just do a thorough investigation before you spend any money.
     
    1 person likes this.
  7. Fernpatch

    Fernpatch Member

    Messages:
    572
    Likes Received:
    19
    Joined:
    Jul 28, 2008
    Location:
    Bellingham,WA
    If you need cheap parts for that b2 motor let me know, I have three of them sitting in my shop that I would be willing to part out.
     
  8. dacheat

    dacheat ..is grounded.

    Messages:
    4,216
    Likes Received:
    205
    Joined:
    Jul 7, 2007
    Location:
    strongbadia
    rep for you, it was a bad spark plug wire. :thumbsup:

    still gonna reset the ECU and see if the codes are there though... :huh:

    hmm - i'll keep that in mind! i'm kinda thinking about getting this one through the 300k mark and then swapping in a D16Z6...but good to know i have options.
     
    Last edited: Mar 10, 2010
  9. 95b16coupe

    95b16coupe New Member

    Messages:
    6,538
    Likes Received:
    224
    Joined:
    Nov 6, 2008
    Location:
    ct
    Woo Hoo! gotta love a girl who can fix her car. i'd be happy if mine even knew what a spark plug wire is. lol
     
  10. dacheat

    dacheat ..is grounded.

    Messages:
    4,216
    Likes Received:
    205
    Joined:
    Jul 7, 2007
    Location:
    strongbadia
    well now..if i had thought to make sure the wires were in their little brackets i wouldn't have had this situation (i think i pinched the bad one on top of the valve cover when closing the hood and it wore out over time).

    but i'm learning!! :ph34r:
     
  11. 95b16coupe

    95b16coupe New Member

    Messages:
    6,538
    Likes Received:
    224
    Joined:
    Nov 6, 2008
    Location:
    ct
    good job on learning.

    it's better to know how to do maintenence than repairs!
     
  12. TurboRex90

    TurboRex90 Golden EG

    Messages:
    1,250
    Likes Received:
    31
    Joined:
    Jul 15, 2008
    Location:
    Maryland

    :concur:
     
Verification:
Draft saved Draft deleted

Share This Page