1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

vtec and rpm problem???!?

Discussion in 'HYBRID -> EG-EK / DC' started by jonocivic69, Oct 4, 2008.

  1. jonocivic69

    jonocivic69 New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Oct 4, 2008
    I tonight changed the ditributor on my eg5 civic vtec, but stupidly snapped the pressure switch cap on what i believe is the vtec solenoid in half leaving half of it still inside the housing. would that be the reason why my car will not go above 3,500rpm in any gear, and limts me to 65 mph? :eek:
     
  2. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    it could be that or a bad dizzy, do you have any check lights on
     
  3. jonocivic69

    jonocivic69 New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Oct 4, 2008
    yes my engine management light is on constantly.
     
  4. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    first thing to do is check the codes and see what they are
     
  5. jonocivic69

    jonocivic69 New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Oct 4, 2008
    ive had her on a diagnostic machine. ENGINE SPEED SENSOR is what was coming up. Could it just be that i need to replace the snapped connector with a new one?
     
  6. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    yes vtec will not work unless you have a good vehicle speed sensor
     
Verification:
Draft saved Draft deleted

Share This Page