1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Vtec problem still...

Discussion in 'HYBRID -> EG-EK / DC' started by kylelohrenz, Dec 10, 2006.

  1. kylelohrenz

    kylelohrenz Junior Member

    Messages:
    31
    Likes Received:
    0
    Joined:
    Dec 6, 2004
    Okay, just did a swap on a 97 civic with a OBD1 B16. I still have intermittent vtec. The motor is reaching temp and not throwing any codes. The car vtecs sometimes through three gears and then not the next at all. I metered wiring from the solenoid and the pressure switch to the ECU and meters perfect from pin to sensor. I replaced the thermostat because it was stuck open, still no steady vtec. Any suggestions? Thanks.
     
  2. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    check the oil pan for dents and do an oil change.
     
  3. kylelohrenz

    kylelohrenz Junior Member

    Messages:
    31
    Likes Received:
    0
    Joined:
    Dec 6, 2004
    Thanks for the reply. No dents in the pan and just did an oil change. Any other suggestions?
     
  4. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    check the screen on the solenoid and clean it with some carb cleaner.

    if you have an oil pressure gauge, what is it reading? usually intermittent vtec is caused by a clogged screen, lack of oil, or some kind of CEL.
     
  5. TheManRSW

    TheManRSW TheManRSW

    Messages:
    387
    Likes Received:
    1
    Joined:
    Oct 18, 2006
    Location:
    Mooresville, NC
    What ecu/pcm are you using? Did you convert correctly from OBDII to OBDI? Is it a J-spec engine...Does it have the oil pressure sensor on the VTEC solenoid? My J-spec didn't but I also had the J-spec ecu that came with the engine so it wasnt looking for it.
     
  6. kylelohrenz

    kylelohrenz Junior Member

    Messages:
    31
    Likes Received:
    0
    Joined:
    Dec 6, 2004
    I'm using an p30 with an obd conversion harness. It is a j-spec motor and has the pressure sensor below the solenoid. This motor and ecu were in another car of mine and ran perfect unitl the swap.
     
  7. kylelohrenz

    kylelohrenz Junior Member

    Messages:
    31
    Likes Received:
    0
    Joined:
    Dec 6, 2004
    I will clean the screen tommorrow and see what happens. Thanks!
     
Verification:
Draft saved Draft deleted

Share This Page