1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

vtec problem...????

Discussion in 'ECU's, Electronics, and Tuning' started by capzzz, May 18, 2008.

  1. capzzz

    capzzz New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    May 5, 2008
    i just bought a 93 hatch swapped with a si motor.....now the vtec wasnt working..... brought it in 2 a buddys shop....got a computer pretty shure its p28 chipped not 2 shure....and he hooked up my vtec cause the wires wernt there be4... drove it for 3 weeks and it worked fine....so now when i drive it.....and i hit the vtec......when i slow down the engine light comes on.....but it feels liek the vtec is stuck on.... liek it pulllsssss wayyyy more..... any help 2 what the problem is.... thnx..n again im not 2 much of the car guy thnx
     
  2. BrutalB83

    BrutalB83 Brutal Moderator Moderator VIP

    Messages:
    11,620
    Likes Received:
    302
    Joined:
    Jun 24, 2006
    Location:
    Rochester Hills, MI
    Is the check engine light on?
     
  3. capzzz

    capzzz New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    May 5, 2008
    yes it on after i hit the vtec........but if i drive it normal and dont hit the vtec its goood... no light .......even if i turn the car off and turn it back on the cheack engine light goes away untill i hit vtec again....
     
  4. BrutalB83

    BrutalB83 Brutal Moderator Moderator VIP

    Messages:
    11,620
    Likes Received:
    302
    Joined:
    Jun 24, 2006
    Location:
    Rochester Hills, MI
    Well I'd take it somewhere and get it diagnosed then (or do it yourself if you know how). It sounds like the car might be in limp mode. The quickest way to figure out what's wrong with it though, is to get the warning light diagnosed...
     
  5. capzzz

    capzzz New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    May 5, 2008
    what do you mean bye limp mode....and not 2 mention......when the engine light is on.... it feels liek the vtec is stlll on.....liek the ca pullss hard....but when the vtec kickes in......it boggles liek chokes...
     
    Last edited: May 18, 2008
  6. svaby

    svaby Drive and Ride A Honda

    Messages:
    16
    Likes Received:
    1
    Joined:
    May 19, 2008
    Location:
    Ohio
    dang thats weird... maybe the wiring to the oil pressure switch or somthing is messed up
     
  7. BrutalB83

    BrutalB83 Brutal Moderator Moderator VIP

    Messages:
    11,620
    Likes Received:
    302
    Joined:
    Jun 24, 2006
    Location:
    Rochester Hills, MI
    When you get a check engine light the car will go into limp mode. This means that it won't let you rev past a certain point. That way, you won't hurt the engine until whatever is causing the check engine light to come on is fixed.

    Like I said, if the light is on, then you need to get it diagnosed by a shop. Hell, just take it to Auto-Zone and have them use their scan tool on it if you don't want to pay a shop, or just read the article in the FAQ section on how to pull the codes yourself.

    It could be any number of things causing the light, you really need to figure out what it is before you start messing with stuff...
     
  8. capzzz

    capzzz New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    May 5, 2008
    thnx..... it was the vtec oil pressure switch.....changed it..... and it still did it....brought it back 2 the shop..... and and the said it might be a bad ground wire somewhere. changed all the grounds and its all perfect thnx
     
Verification:
Draft saved Draft deleted

Share This Page