1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Vtec solenoid in a B16a1 OBD0

Discussion in 'General Tech and Maintenance' started by Drunkencat, Jun 24, 2009.

  1. Drunkencat

    Drunkencat New Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    Dec 17, 2006
    I've been having a oil leak coming out of the Vtec solenoid and found out its not the seal. I've also failed emissions and if I don't let the car warm up for 5 mins I will have an idle issue were it goes from 500 rpm to 1500 rpm back and forth when I stop. I've dropped it off at the mechanic and after hooking it up to the computer he says the Vtec solenoid is bad. He says he is going to check with Honda for a solenoid but I have fears that they may not carry it since this generation of engine was not in the USDM. My other fear is if they have it they may want an arm and a leg for it. So my question is what vtec B16 solenoid will work for this B16A1 OBD0 engine? Do all B16 vtec solenoids work? I've search for this information and have found nothing.
     
  2. Drunkencat

    Drunkencat New Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    Dec 17, 2006
    Ttt
     
  3. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,417
    Likes Received:
    154
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    I would think they're the same but don't quote me. The hunting idle don't sound like a VTEC thing....or failing emissions.
    But maybe someone has had a similar experience and can prove me wrong.

    I would check the IACV and maybe see if the screen is clogged. That might fix the hunting idle.
     
Verification:
Draft saved Draft deleted

Share This Page