1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

why is IAT light on?

Discussion in 'Civic and del Sol - EG and EK' started by Taco15, May 21, 2012.

  1. Taco15

    Taco15 I wear stretchy pants VIP

    Messages:
    6,998
    Likes Received:
    203
    Joined:
    Jan 11, 2005
    Location:
    Tallahassee Fl
    Sup fellas! Long story short I swapped my JDM type R in a 2000 Si that I bought for cheap. The IAT sensor is on the intake tube where the IAT on the type R is on the manifold.

    I have it hooked up on the intake tube just like the B16 had it but the light stays on and won't go away.

    I'm running a chipped and tuned P28. before I cut the harness and change the plug to fit the ITR sensor is there anything else I should consider? It runs fine, idles low every once in a while but nothing a throttle bump can't fix.

    It's for sale too ;)
     
  2. K2e2vin

    K2e2vin Senior Member

    Messages:
    8,446
    Likes Received:
    92
    Joined:
    Jan 2, 2003
    Location:
    Raleigh, NC
    Maybe bad IAT? Something like that happened to me; I just happened to have another IAT sensor; swapped it over, and the light was gone.
     
  3. Taco15

    Taco15 I wear stretchy pants VIP

    Messages:
    6,998
    Likes Received:
    203
    Joined:
    Jan 11, 2005
    Location:
    Tallahassee Fl
    i guess it would be my luck with it going bad but it never left the intake tube while swapping the motor :lol:

    I'll cut the plug and replace it with the one that goes to the ITR manifold and see if it goes away. I deleted some of the emission crap which is on the B16A2 t-stat housing plugging up to the canister on the firewall. I deleted it and left the canister purge unplugged....nothing going to it so WTH. that would cause anything will it?
     
Verification:
Draft saved Draft deleted

Share This Page