1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Why Is My Check Engine Light Coming On?

Discussion in 'Forced Induction' started by BIGTYME, Apr 28, 2003.

Thread Status:
Not open for further replies.
  1. BIGTYME

    BIGTYME Banned

    Messages:
    12
    Likes Received:
    0
    Joined:
    Apr 28, 2003
    OK... I HAVE A '94 DEL SOL WITH A '00 CIVIC SI ENGINE AND THE GREDDY TURBO KIT FOR THE '00 SI ALSO.

    EVERYTHING SEEMS TO BE RUNNING OK, EXCEPT WHEN I AM IN 3RD AND I GO FULL THROTTLE, MY CHECK ENGINE LIGHT COMES ON. AND THEN IT STARTS REVING FUNNY. IT WILL GO UP AND DOWN FROM ABOUT 800 RPM TO 1300.

    I AM ALSO RUNNING RICH AND I ALSO DONT KNOW WHY, COULD I JUST NEED TO GET THE "MISSING LINK"

    PLEASE HELP.

    STEVE

    :hitit:
     
  2. liquid00meth

    liquid00meth Senior Member

    Messages:
    3,201
    Likes Received:
    0
    Joined:
    Nov 26, 2002
    Location:
    Laconia, NH
    if you have nothing stopping your map sensor from seeing boost, yes. You need to install a missing link or ghetto rig some aquarium check valves.
     
  3. cws13

    cws13 Senior Member

    Messages:
    484
    Likes Received:
    0
    Joined:
    Nov 15, 2002
    Location:
    Athens,GA
    That is a bolt on kit and shouldn't be causing problems...what is the code?
     
  4. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    who cares, he was banned
     
Thread Status:
Not open for further replies.

Share This Page