1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wiring H22a into CD5 accord???HELp!

Discussion in 'Accord' started by unknown, Dec 27, 2010.

  1. unknown

    unknown New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Dec 27, 2010
    Iv currently removed my F22b-1 sohc vtec engine out of my 97 accord. The H22a donor engine from a 94 prelude is in the accord no worries! was a easy fit, as the chassis come factory SiR....... The problem i have is, all the plugs to the sensors on the left hand side plug up, only have one stray plug, but on the crank side, i have the loom from the ECU with 5 or 6 large multi pin plugs. 1or 2 plugs from h22a engine plug up directly (the wire colors done match) but the rest of the plugs dont. I cant find a wiring diagram for my car anywhere on the net.. Also i have the ENTIRE dash loom from the h22a and the p13 ecu, i found the plugs to meet the engine (same wire colors ofcourse). i would just use this whole loom but id rather not have to wire the whole loom in, i would even know where to start.. Im very much a learner and have no qaulifications on this feild, im solely taking on a challenge. Any help would be great.. this exact conversion has been done plenty according to the net. All the homework iv done prior to swap suggests there are little wiring issues to sort but not from what i see, although im yet to find a exact thread on the same year motor and exact same car.

    CHASSIS:
    '97 vti cd5 accord

    DONOR:
    '94 H22a1 - prelude
     
  2. dilbeckskate

    dilbeckskate infamous

    Messages:
    3,107
    Likes Received:
    195
    Joined:
    Aug 20, 2010
    Location:
    Kennesaw Ga
    Pics ?
     
  3. unknown

    unknown New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Dec 27, 2010
    Yeah was just thinking that! will post some tomoro for sure!
     
  4. unknown

    unknown New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Dec 27, 2010
  5. unknown

    unknown New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Dec 27, 2010
  6. Hondadude141

    Hondadude141 ¿pɐǝɥ ɹn ɥʇıʍ uıop nɥɔʇɐʍ

    Messages:
    2,621
    Likes Received:
    108
    Joined:
    Jul 17, 2007
    Location:
    TX
    Someone correct me if I'm wrong, but since you are trying to wire up an OBD1 engine into an OBD2 harness it won't work and you are going to have to yank another harness as well as either a jumper harness or ECU off of an OBD1 car.
     
  7. unknown

    unknown New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Dec 27, 2010
    i have the whole loom from the prelude the motor comes from.. it has all the plugs that meet the engine. are you telling me i must use that loom? will it fit the accord? i have the p13 ecu that goes with the engine aswell. i got a whole prelude and stripped it..
     
  8. calmfornow

    calmfornow System Failure Racing

    Messages:
    210
    Likes Received:
    3
    Joined:
    May 24, 2007
    Location:
    Zionsville, pa
    well you may have the whole prelude but that wont help you, you need a engine harness that is produced from 96 and up, but my recomendation would be.....use your accord harness, the clips should be the same, if anything you will have to extend a few clips, but it will work
     
    1 person likes this.
  9. josh_crewdson@y

    josh_crewdson@y New Member

    Messages:
    438
    Likes Received:
    4
    Joined:
    Dec 5, 2007
    Location:
    nova
    x2 use the accord harness and and whatever is needed to that.
     
  10. unknown

    unknown New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Dec 27, 2010
    got it running today! thanks a bunch for all your help! these forums are great!
     
  11. Ethan

    Ethan Well-Known Member

    Messages:
    2,945
    Likes Received:
    98
    Joined:
    Jun 30, 2008
    video of it running? pics of it finished?
     
  12. CDelgado

    CDelgado New Member

    Messages:
    91
    Likes Received:
    0
    Joined:
    Jan 6, 2009
    Location:
    Derwood,Maryland
    How'd you get it running? Which advice helped? Post it up so others can benefit
     
  13. accordracerH22

    accordracerH22 New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Jan 4, 2011
    Thats exactly what i had to do to mine. I have a 96 accord with obd2. it runs greats. A few extentions and it runs great.
     
  14. unknown

    unknown New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Dec 27, 2010
    havent finished it yet. because my car has full custom exhaust im having trouble finding a flange to weld the factory downpipe to exhaust, ill get there tho. the biggest peice of advice i can give is change the power steering hose from accord to bb1 prelude while engine is out, SSSoooooo much easier! Correct thing to do it take both hoses into a shop and get prelude end that bolts to pump attached to accord steel line. I didnt to this, i fractionally bent the line from the prelude, wiggled it and forced it to bolt up, saved me $$! use original engine loom from original engine, add few plugs from dohc engine loom and attach to original loom. some wires need extending, cant remember which ones off hand bu they were completely obvious. I stuck at this project, took me awhile, i was in no rush. pics and videos of it running real soon!
     
  15. unknown

    unknown New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Dec 27, 2010
    did you have 2 plugs on the right hand side off orignal loom that dont reach to the plugs they meet, iv tried extending the wires but made no difference to it running.
     
  16. hondamatt

    hondamatt New Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Jul 15, 2010
    man lm doing same kinda swap but ive done all research. l swapped motor over to obd2 crank position sensors and all. but l ran into dizzy being different dunno how to fix besides hard wire them or butt connect. and intermediate shaft from accord cant get axle nut onto w/o stretching axle. also doing auto-5speed swap any help?
     
  17. unknown

    unknown New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Dec 27, 2010
    umm im not sure bout dizzy, all i did was leave original h22a dizzy on and cut and wired my obd2 engine harness to the dizzy plug. google obd2 to obd1 dizzy wiring, i found a diagram. as for the cvs, the half shaft on the prelude dont work, use the accord shaft, it workd for me!
     
  18. unknown

    unknown New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Dec 27, 2010
    my accord is 97? im having serious trouble getting it to run prop? is your 96 accord chassis harness obd2? i have most sensors pluged up, runs low idle really roughly! are you using p13 ecu? was the h22 u put in h22a1?obd1?
     
  19. iLLest11

    iLLest11 New Member

    Messages:
    20
    Likes Received:
    0
    Joined:
    Sep 28, 2011
    just came across this thread im having the same problem on my cd5 with the wireing loom not matching not sure what to do or where to start..tryed doing some reserch but no luck. Btw my accord is a 95 had f22b2. if any one can point me to the right direction or have a solution would be appreciated thanks.
     
Verification:
Draft saved Draft deleted

Share This Page