1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WTF? Distributor bad?

Discussion in 'Civic and del Sol - EG and EK' started by KyleKidd, Oct 6, 2008.

  1. KyleKidd

    KyleKidd Honda Noob

    Messages:
    120
    Likes Received:
    0
    Joined:
    Sep 7, 2008
    Location:
    NorthEastern Pennsylvania
    Ok so I've been having this really bad putting problem in my 93 Del Sol D16Z6. I posted a description of prob here: http://hondaswap.com/civic-del-sol-eg-ek/need-some-help-please-181227/#post1122472.
    So i have done a lot already to try and fix it.
    Replaced gas filter, cleaned IAV, REplaced oil + oil filter, Timed it, replaced all fuses, No CEL light.
    Ok, so today i drive about 15 miles to my nearest autozone, on the way i thought i wouldent make it the putting was so bad. I finaly do get there, buy spark plugs, a radiator cap (old one is just really old), distributor cap + rotor, oxygen sensor for after the manifold or something, and a wireset. So at the autozone dealership (in the parking lot), i removed my old wireset, distributor cap+ rotor, and replaced them with the new ones i just bought. I had NO PROBLEMS OR PUTTING for almost 12 miles. I honestly thought i fixed it. Then all of a sudden, boom outa no-where it started up again. And i've had the problem since, so its not just after the engine got hot or whatever.
    Now i do have an oil leak in my engine somewhere, idk if that could have anything to do with it. But wouldent you think it has something to do with my distributor if everything worked fine and perfectly for almost 10 miles after i changed the rotor+cap+wires? then suddenly started all up again?
     
  2. YBLEGAL

    YBLEGAL Regular Member w/ Cheese

    Messages:
    2,762
    Likes Received:
    36
    Joined:
    Aug 9, 2006
    Location:
    NW Indiana
    Did you ever change the valvecover gasket/spark plug valve cover rings?

    My friend's 4G63 was leaking oil there, and grounding out the spark plug wires, ruining them like that.

    Do a leak down test?
    Compression check?
    Valve adjustment?

    idk
     
  3. KyleKidd

    KyleKidd Honda Noob

    Messages:
    120
    Likes Received:
    0
    Joined:
    Sep 7, 2008
    Location:
    NorthEastern Pennsylvania
    no i havent tried that but i definatly will. Im going to change the O2 sensor and spark plugs today, maybe that will help.
     
Verification:
Draft saved Draft deleted

Share This Page