1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wtf!!!!!!

Discussion in 'HYBRID -> EG-EK / DC' started by RtoXgo7, Apr 30, 2007.

  1. RtoXgo7

    RtoXgo7 "Honda Power"

    Messages:
    5
    Likes Received:
    0
    Joined:
    Oct 31, 2006
    Location:
    S,L,C
    I really need help on this one. ok i was somewhat racing my car and everything was going fine till my check engine light went on then my car died right as i got home (thank god) and now it wont start. i found out that the ecu fuse in the fuse box under the hood is blown so i put a new one in and tryed to start the car but every time i turn it to the on postion it blows the fuse. i dont get it!!! :mad: i didnt touch anything it just happened while i was driving i guess. someone please if you can help let me know!!!:confused: :confused: :confused:
     
  2. klyph

    klyph Dismember VIP

    Messages:
    6,342
    Likes Received:
    262
    Joined:
    Aug 14, 2006
    Location:
    North Pole, AK
    That circuit is grounding somewhere. trace the wires.
     
  3. get_nick

    get_nick These snozzberries taste like snozzberries... VIP

    Messages:
    11,939
    Likes Received:
    1,059
    Joined:
    Apr 21, 2003
    Location:
    Washington State
    check the other fuses under your hood.
     
  4. RtoXgo7

    RtoXgo7 "Honda Power"

    Messages:
    5
    Likes Received:
    0
    Joined:
    Oct 31, 2006
    Location:
    S,L,C
    all the other fuses are good the ecus is the only one messed up. ill look to see if any wires went a stray.
     
  5. get_nick

    get_nick These snozzberries taste like snozzberries... VIP

    Messages:
    11,939
    Likes Received:
    1,059
    Joined:
    Apr 21, 2003
    Location:
    Washington State
    swap in a known good ecu. yours may be bad now.
     
  6. MXDesa

    MXDesa Senior Member

    Messages:
    927
    Likes Received:
    2
    Joined:
    Apr 19, 2003
    Location:
    Queens, New York
    See if your oxygen sensor is grounding against the exhaust pipe/manifold.
     
  7. klyph

    klyph Dismember VIP

    Messages:
    6,342
    Likes Received:
    262
    Joined:
    Aug 14, 2006
    Location:
    North Pole, AK
    Don't swap ecu's 'til you've found the source of the ground, as you may fry the new one if the problem is not corrected.
     
  8. RtoXgo7

    RtoXgo7 "Honda Power"

    Messages:
    5
    Likes Received:
    0
    Joined:
    Oct 31, 2006
    Location:
    S,L,C
    ok i found out that it was a ground wire that was loose and that a wire from the ecu had come undone. i looked at all the other wires, played with them and just had a deep look at everything in the engine bay then tried it and it worked.
     
  9. klyph

    klyph Dismember VIP

    Messages:
    6,342
    Likes Received:
    262
    Joined:
    Aug 14, 2006
    Location:
    North Pole, AK
Verification:
Draft saved Draft deleted

Share This Page