1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

z1/z6 minime turbo build ,need help

Discussion in 'Engine Building' started by gsrcivic9, Dec 12, 2009.

  1. gsrcivic9

    gsrcivic9 New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jul 5, 2008
    Location:
    bronx n.y.
    i have a d15z1 block with a d16z6 head. i put a adjustable cam gear on it to compensate for the half tooth off issue. but i dont know if im supposed to time the cam as a z1 or a z6 since they have different marks. ive been searching every writeup and posting i can find but nothing says anything with a z1 block. as of right now its running timed as a z6 with the cam gear being off 4.75 degrees after being set at 0 to catch the belt. i tired the best i could to set base timing but the motor idles to bad to get a good reading. i bleed to whole coolant system over and over and i even swaped iacv's. i even ordered a new custom base map for my setup and that hasnt helped the surging idle and the too rich condition at idle, also there is no power loss and it runs great at higher rpms, just at idle under 1k it wont run right.
    please if anyone knows the exact specs the z1/z6 minime is supposed to be set at let me know!!!!
     
  2. d-mon

    d-mon what r u compensating 4?

    Messages:
    125
    Likes Received:
    4
    Joined:
    Jul 1, 2008
    adj cam gear should be advanced 4.75* from stock Z6 setting.
    sounds like your 1 tooth off, barely idling after engine warms up.
     
  3. gsrcivic9

    gsrcivic9 New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jul 5, 2008
    Location:
    bronx n.y.
    ok got it running last night after a frustrating day of troubleshooting. my first problem was i found that the q31 transistor in my p28 ecu was burnt. i removed it and soldered a new one in. dont know why it was burnt but car was running perfect before , and i new removed the im from car just unbolted and moved it back a few inches, and i rechecked the iacv and purge valve wires and they were correct. but afgter i replaced it it started running alot better. then i was able to adjust the cam gear to 5 degrees advanced were it ran best and then timed the dizzy to 16 degrees and now its running good. also my turbo is spooling alot faster and sooner and i got alot more power at low end too. i was skeptical about this z1/z6 build but it worked out better for the turbo set up with the custom basemap than i thought.
     
  4. crazyhonnybadger87

    crazyhonnybadger87 New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    May 27, 2012
    What was Ur horsepower like I'm doing the same build
     
  5. E_SolSi

    E_SolSi Member of the 20 nut club Moderator VIP

    Messages:
    30,036
    Likes Received:
    3,970
    Joined:
    Sep 28, 2002
    Location:
    CT
    this thread is 2.5 years old
    the OP has not been here in about 2.5 years
    i dont think you will be getting a reply from him on this
     
  6. crazyhonnybadger87

    crazyhonnybadger87 New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    May 27, 2012
    Well damn oh well guess Imma have to find out my self
     
  7. E_SolSi

    E_SolSi Member of the 20 nut club Moderator VIP

    Messages:
    30,036
    Likes Received:
    3,970
    Joined:
    Sep 28, 2002
    Location:
    CT
  8. phunky.buddha

    phunky.buddha Admin with a big stick Admin VIP

    Messages:
    28,465
    Likes Received:
    228
    Joined:
    Sep 30, 2002
    Location:
    Dallas / Fort Worth, TX
    Honestly, I'd estimate the same as any other D15/Z6 "mini-me" setup that's tuned well- but there are too many variables when you add boost to figure out what kind of power you're going to make. Everybody tunes differently.
     
Verification:
Draft saved Draft deleted

Share This Page