1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ZC HELP!

Discussion in 'HYBRID -> ED-EF / DA' started by vtechkidd, Aug 25, 2003.

  1. vtechkidd

    vtechkidd Junior Member

    Messages:
    19
    Likes Received:
    0
    Joined:
    May 22, 2003
    OK, this is for all you gearheads out there. i need help. heres my story, started a ZC motor swap, 5 weeks ago. got it dropped in and wired up, it wouldnt start. so i had it towed to a performance shop about 4 weeks ago to solve the problem because i thougt it was electrical. My ECU has been throwin codes 4,7,9 all at once, sometimes not at all, and seperatley. I have replaced, TPS sensor, Cam angle/cylinder POS sensor, TW sensor, 4 different distributors, 4 ECU's. now heres my prob, my car will start but cough black smoke out of my exhaust and itt will pop and sputter real bad, it idles ok but it runs crappy. i still throw codes 4 and 9. this seems IMPOSSIBLE to me because i KNOW that these work. when you test for continuity through the harness at the ecu, everything is in factory spec. but ECU is throwin codes still. soi went and replaced the comp, 4 times!! still the same prob. my mechanics are stumped. the only thing left to do is to hard wire the prob (distrib, cyp sensor) to the ecu str8 from the sensors(skipping the wire harness) im out of time and patience, anyone EVER had any prob similar to this? all fuses are fine, its timing is fine. please help, sorry for the long post, but im stuck. thanks
     
  2. Jdubspeeds

    Jdubspeeds Senior Member

    Messages:
    503
    Likes Received:
    0
    Joined:
    Jun 9, 2003
    Location:
    Tacoma Wa
    Have you reset your ecu or tried another one? Just unplugging it will not reset ghost codes. I had a running problem with mine call for code 16 and I took it to a speedshop to have it looked at, and all they did was reset the ecu and it was fine.
     
  3. vtechkidd

    vtechkidd Junior Member

    Messages:
    19
    Likes Received:
    0
    Joined:
    May 22, 2003
    yeah my mechanic said he reset the ECU so........................
     
  4. jlicrx

    jlicrx Senior Member

    Messages:
    1,891
    Likes Received:
    65
    Joined:
    Jun 5, 2003
    Location:
    Colorado Springs
    is this DOHC ZC or SOHC ZC? what model is the car? what wiring harness did you use?
     
  5. vtechkidd

    vtechkidd Junior Member

    Messages:
    19
    Likes Received:
    0
    Joined:
    May 22, 2003
    DOHC ZC into an 88 crx Si
     
Verification:
Draft saved Draft deleted

Share This Page