1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Zc Ignition? Or Fuel Pump?

Discussion in 'Engine Building' started by jamiedude, May 26, 2003.

  1. jamiedude

    jamiedude Senior Member

    Messages:
    150
    Likes Received:
    0
    Joined:
    Jan 23, 2003
    Location:
    chesapeake,va
    hi,
    I have a 91 civic with a zc i got very cheaply. i only want the car to get me to work(long live the beater) and back while i work on my rex. now the problem is the zc doesnt want to cooperate this month. i just reacently changed the coil and the ignitor pack inside the distributor. she fires back up but now as i accelerate into the rpms the motor misses terribly.
    it will do just fine if i just putt putt round town but not for long. i keeps turning off on me in mid motion.I am just cruising at like 30 and the next thing i know my foot doesnt have the feeling anymore, like it does when the engine is running. i wait a few second and start it then i try to putt putt through traffic some more.

    i dont know what the hell it could be im not a mechanic im a damn welder but ive always done my own work.

    any help would be highly appreciated.

    thanks

    Jamie
     
  2. Viperlocc_B18C1

    Viperlocc_B18C1 Senior Member

    Messages:
    115
    Likes Received:
    0
    Joined:
    Mar 3, 2003
    Location:
    Madison, WI
    ignition wont make u idle funny, kill ur car while in mid motion, and start up again after letting it sit. its ur pump/filter/regulator/injectors/lines......i say replace the filter first and then the pump...then the regulator and then lines and then finally the injectors...
     
  3. jamiedude

    jamiedude Senior Member

    Messages:
    150
    Likes Received:
    0
    Joined:
    Jan 23, 2003
    Location:
    chesapeake,va
    fuel filter would clog it up that bad?

    im still thinking it has something to do with the timing.

    im gonna look into it soon when it stops raining.

    thanks
     
  4. Sed8ed

    Sed8ed New Member

    Messages:
    136
    Likes Received:
    0
    Joined:
    Sep 29, 2002
    Location:
    Vancouver B.C.
    This happened to me on my old accord... it was the fuel pump relay. Does it sometimes start, only to die right away then not start for 10 or so minutes? and does it die when you floor it. The first symptom was the begining, later the dying while driving occured
     
  5. jamiedude

    jamiedude Senior Member

    Messages:
    150
    Likes Received:
    0
    Joined:
    Jan 23, 2003
    Location:
    chesapeake,va
    it does exactly what you just said sed8ed.

    fuel pump relay? :eek:

    awww dammit <_< this is right above the gas tank isnt it?

    thanks
     
Verification:
Draft saved Draft deleted

Share This Page