1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ZC running rich

Discussion in 'General Tech and Maintenance' started by cheese9988, May 30, 2004.

  1. cheese9988

    cheese9988 Senior Member VIP

    Messages:
    1,990
    Likes Received:
    251
    Joined:
    Apr 25, 2003
    Location:
    Lowell, MA
    I believe that my zc is running a little rich, I can smell fuel when the motor is running and there is alot of black carbon on the tailpipe which a assume is a product of this. Is this a bad thing and is there a way to correct this problem? It is a stock `88 zc blacktop motor running an stock pm7 ecu.
     
  2. Sobe_Death

    Sobe_Death Senior Member

    Messages:
    216
    Likes Received:
    0
    Joined:
    Sep 15, 2003
    Location:
    ATL, GA
    do you have an adjustable FPR? if so the pressure may be too high. however, on my pm7, i too can smell the fuel and i get carbon deposits on the rear bumper. if the soot is just in the tailpipe, then its ok. when you start to see it all over the back of your car is when its running way too rich and should try something else.

    you may also want to try a new o2 sensor or try putting a pm6 on there to see if that solves the problem. try checking the timing too.
     
  3. cheese9988

    cheese9988 Senior Member VIP

    Messages:
    1,990
    Likes Received:
    251
    Joined:
    Apr 25, 2003
    Location:
    Lowell, MA
    Ya its not adjustable, carbon isn't all over just on the inside of the pipe. I switched from a pm6 to a pm7, I still have it but I like the new ecu better. I put a new o2 sensor on there when I did the motor swap, it has maybe 500 miles on it if that.
     
  4. Floydy

    Floydy Member

    Messages:
    69
    Likes Received:
    0
    Joined:
    May 18, 2004
    Location:
    Vero Beach, Florida
    My zc runs rich too, and I could never figure out why. Its probably the ecu.
     
  5. bloodspider2042

    bloodspider2042 Junior Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    May 31, 2004
    it mite be that your running a pm7. becouse that is what my friend is running and he runs rice also. im running the si (pm6) computer with my zc and it does not run rich but thats just me
     
  6. Sobe_Death

    Sobe_Death Senior Member

    Messages:
    216
    Likes Received:
    0
    Joined:
    Sep 15, 2003
    Location:
    ATL, GA
    well, all-in-all, the pm7 is a pm6 with more aggressive fuel maps, so it should be running a little richer, but in this case its usually a personal preference thing.
     
  7. Repooc901

    Repooc901 Junior Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    May 31, 2004
    i got the same issue with my f22 so what ecu swap would be recommended to fix it
     
Verification:
Draft saved Draft deleted

Share This Page