B18a1 not running properly

We may earn a small commission from affiliate links and paid advertisements. Terms

96ekhatch

New Member
I swapped a b18a1 into my ef hatch and at first it wouldn't run right we found out plug wire's 2 and 3 were mixed up. Well we fixed that and now it still doesn't run right its fast but when its idling it pops and backfire's a little. While i'm driving it and push in the clutch and let off the gas to shift it will backfire also. I checked the timing belt and one of the cam's look like they r off a tiny bit from the other one but not a whole tooth off, what else could it be making it not run properly i have brand new plug's and the wire's r still good.
 

96ekhatch

New Member
no i haven't tried anything yet but i will try that tomorrow if the weather is ok. Could the timing belt be stretched out and thats y it doesn't run right idk how old it is but i'm planning on replacing it soon.
 

drummingpariah

Author of the Madness Man
Also check your vac lines, make sure they're all hooked up. Is the ECU throwing any codes?

There could be a number of things causing backfires, generally they're caused by running too rich (limp mode runs in a closed loop and enriches the circuit). Your o2 sensor(s, if it's an obd1 b18a1) could also be bad, causing the ECU to think it's running much more lean than it really is.

I'm not discounting timing here, just adding a few more possible solutions.

If you can, get a video up of how it's running.
 

96ekhatch

New Member
i just remembered that i don't have a coolant temp sensor hooked up cause the one on the motor is broken there's one that goes to the guage but not to the ecu could it be that also?
 

96ekhatch

New Member
could that be the problem that the coolant temp sensor isn't hooked up to the ecu?? somebody help i need to get it running right before i turbo it
 

newb

phresh
VIP
I just gotta ask. What ECU are you runnin?
 

96ekhatch

New Member
the obd0 ls ecu i'm about 99.9 percent positive its the ls ecu but i know for sure that it is obd0. i will check tomorrow what the code on it is but i had people say that it was the ls ecu. While its running it just sputters and in between shifts it will backfire its not huge backfire's like to where it spits flame's but it just putters and i know its not running the exact way it should be.
 
Top