hasport mount bracket

We may earn a small commission from affiliate links and paid advertisements. Terms

c-rex-beat

yeah, it's a vtec.
Hey guys, I have a 89 rex and just swapped in a hydro trans and it all seemed to go all too well. I ordered the hasport hydro kit from h motors and here I go, never done a trans before! the only prob I have is my rear mount and bracket. The bracket mounts to the trans perfectly but is no lining up with the mount at all. Did I somehow mess something up or could it just be wrong bracket? If anyone has had this issue before and have a solution please helpl me out bro.
 

INJEN78

HS LEGEND
i had the same problem,
you do not have the right rear mount bracket,i learned this the hard way on both of my EF swaps,i opted to weld the mount to the rear cross member,where the bracket lined up,if i could go back,i would ave found the right rear bracket
 

c-rex-beat

yeah, it's a vtec.
so basically hasport sent me the wrong one. That sucks. I noticed that on the majority of the parts they all said b series. When I called them they said they all the same except the two mount brackets. WHO KNOWS! lol.
 

jlicrx

Senior Member
VIP
never done one, but is it possible that you need to move the mount on the crossmember to the other set of holes, like you would for a B-series swap?
 

HATCHET_HONDA

scottie fizzle
Hey guys, I have a 89 rex and just swapped in a hydro trans and it all seemed to go all too well. I ordered the hasport hydro kit from h motors and here I go, never done a trans before! the only prob I have is my rear mount and bracket. The bracket mounts to the trans perfectly but is no lining up with the mount at all. Did I somehow mess something up or could it just be wrong bracket? If anyone has had this issue before and have a solution please helpl me out bro.


not lining up? as in the bracket sems too big on the mount or the rear crossmember mount is over just a lil too far and not lining up...? if number 2 is the case you have the mount in the wrong holes
 

c-rex-beat

yeah, it's a vtec.
So I guess I need to relocate the mount. As you can see in the photo the mount is totally left of the bracket.
1017.jpg
 

mikey bottles

Prof. Bottles
are you sure that bracket doesnt mount up on the other side of the trans? as in the bolts go through the trans.. then into the bracket?
 

c-rex-beat

yeah, it's a vtec.
thats the only way it bolts to the trans. I was checking out moving the mount over. There is a bolt hole for the front side and another but it has a rubber in it, can that rubber come out to be replaced with a bolt? looks like it may line up. also whats the best way to remove that mount?
 

HATCHET_HONDA

scottie fizzle
thats the only way it bolts to the trans. I was checking out moving the mount over. There is a bolt hole for the front side and another but it has a rubber in it, can that rubber come out to be replaced with a bolt? looks like it may line up. also whats the best way to remove that mount?

ok you have a rex aand your installin a hasport hydro trans mount kit right? your not using that rear mount in the pic right? you need the hasport one
 

c-rex-beat

yeah, it's a vtec.
yes I have a rex, using hasport hydro kit which included this bracket for the rear mount. It's hard to see in the pic because it's black, but it is pictured right of rear mount.
 

HATCHET_HONDA

scottie fizzle
yes I have a rex, using hasport hydro kit which included this bracket for the rear mount. It's hard to see in the pic because it's black, but it is pictured right of rear mount.


ok...the rear trans bracket should be the right one. if it wasnt it still line up only it would be a lil too wide on that mount on the crossmember. the rex has a b series swap right? cause you should have a new motor mount for the rear crossmember with that kit
 

HATCHET_HONDA

scottie fizzle
did you buy the bracket extra? my swap mount kit didnt come with that rear trans bracket.. i just swiped it off a 93 teg in the junkyard
 

c-rex-beat

yeah, it's a vtec.
it came with kit for hydro swap along with side mount adapter that worked out fine. they said I needed it and aparantly I need someting something there. if it's this one they never mentioned moving the mount over.
 

HATCHET_HONDA

scottie fizzle
oh my bad, d series

oh ok.. so you still have a d series just a hydro trans. hmmm well if you look at the rear crossmember does it appear to line up if the mount moves over to the next hole? if your still using the stock cable d trans mount im thinkin its not gonna work. im pretty sure you need a diff rear mount
 

c-rex-beat

yeah, it's a vtec.
it seems like they would make a bracket to keep stock location of mount. I'll have to call hasport in the morning to work somehing out.
 
Top