Idle problem

TechChris

Member
Hi

Well I got my B18C1 in my 94 Civic. It even runs. Unfortunately I have the dreaded idle problem I cannot get it to idle down lower than about 1800 without pulsating. I am pretty sure my TPS is working. If I loosen the screws and adjust it while the motor is running I can lower the idle. But like I said when it gets down to where it should be it pulsates. If I totally seal the throttle body shouldnt the engine die? If not then I probably have a vacuum leak right? Also does anyone know where I can get a vacuum hose diagram? I have a b18C1 with a Skunk2 intake.

Thanks
Chris
 

EG6_down5hift

Junior Member
check the hose that comes off the fueld pressure regulator, that is some of the most likely cause of problems to happen, and does happen a lot.
 

pills_PMD

Super Moderator
did you try to set the tps properly instead of just guessing?
.5 v closed 4.5 v wot

look in the articles i wrote something up on just this
 

TechChris

Member
Hi All

Just to update my problem. It ended up being the throttle body gasket. I checked everything else. I figured it was a vaccum leak when you tightly cover up the throttle body and it keeps on running. So for those of you with this problem. That is what is was for me. Later all

Chris
 

TechChris

Member
No it was a swap and I put a new throttle body on. I had to order one, no one had one locally. I thought that might be the problem.

Chris
 

TechChris

Member
Hi

I just thought I would let people know what fixed my problem. Just in case they are having the same problem. Mine ended up being a throttle body gasket.

Chris
 
Top