JDM B18C into 98 EX

We may earn a small commission from affiliate links and paid advertisements. Terms


New Member
Okay so I have everything wired up, doing all of this myself.

The engine is ODB2a, the engine harness was/is a ODB2a EX 5spd harness.

Extra sensor by the fuel rail (EGR) was not used.
Crank fluctuation sensor was not used.
Extra VTEC wire was not used.

IAB is wired up (dual butterfly) using P72 JDM ECU

Everything is wired up, windows work, interior light works, cluster works, radiator fan comes on... etc. NO Check Engine Light, only SRS light because I removed passenger air bag.

My question/problem is this: On the intial startup, I had the firing order wrong, and after several attempts of troubleshooting the problem, I realized and solved that issue. The car started fine and idled at around 1500, until I fixed the loose/sticky throttle cable issue and then the car idled at 900-1000 going from my cluster. The fan would kick in every 5-10 minutes and run for 10-15 seconds.

I went for a test drive (around the block) and found liquid sort of coming out of my muffler. It was black and murky and when touched with my hand, it dried up very quickly. It only did this after the first test drive, I just have a huge black spot on my driveway now because it's a hilly driveway.

The car does not accelerate as well as I think it should. What I mean is, the car idles now at around 500 or so, when I press the gas pedal, it shoots down into 300 rpms and then goes up. It goes up very slowly. Upon driving the car, it's loud and obnoxious (i don't mind that) but when I press on the gas pedal, the rpms do not climb and neither does the speed, not fast. In terms of comparison, I think my D16Y8 with a spun bearing would accelerate faster than this thing.

I believe I have done all the vacuum lines correctly. I am using the original intake manifold. Right from the MAP sensor, there is a hose that I connected to the EVAP unit. I also plugged up a vacuum line next to the two coolant lines underneath the manifold, I believe this is next to the TPS.

Cliffs: jdm b18c started fine, one day later idles at 300-500 after adjusting throttle cable tensioned with pedal.

I am still using the same spark plugs which have NOT been gapped. I have purchased a brand new set but I need them gapped prior to installation.

I have replaced the timing belt, water pump, tensioner pulley, dizzy rotor, spark plugs, spark plug wires. There are no leaks present of any sort.

the hell is going on??


New Member
....Never messed with the head on a honda before but I worked on a chevy 350 head before and didn't notice the bolt stuck in the exhaust valve. When we started it up it drained gas out the exhaust.....with post detination lol Is this murky fluid gas? You got me stumped. I feel that its either in your head(not a joke) or its ecu.


Honda Minion
The PCV is plugged? (under the IM) It should be hooked up b/c its positive crank ventilation and I would have it hooked up (not sure if this is the reason for lack of power but maybe)

Line off the TB (next to MAP) goes to the charcoal canister (I think this is what you meant by EVAP unit)

JDM B18C doesn't have the need for the oil pressure switch for VTEC like USDM motors do, so as long as its also a JDM ECU (like you mentioned).....that part should be fine.

The liquid......how long was the car sitting before this swap? What I mean is....could this be old stuff in the exhaust or from the swap?

I do not think idle is the issue of this lack of power but.....

To Adjust the idle:

1) Get car to running temp (aka fan comes on).
2) Turn car off
3) Unplug electrical clip on the IACV
4) Start car back up (may need to give it a little gas pedla b/c it will idle low with IACV unplugged)
5) With IACV Unplugged and car running.....adjust the idle screw on the TB (flat head does the trick)
6) Adjust idle to where the tach reads about 450-500 rpm (this is hard to see on a stock tach but get it close)
7) Turn car off
8) Plug IACV electrical back in
9) Unplug the "Back-Up" fuse for 15 seconds or so
10) Plug the fuse back in and re-start......see where it idles then.


New Member
Thanks man.

It turned out to be the timing belt, off by one tooth on the crank.