Ls/vtec Problems

We may earn a small commission from affiliate links and paid advertisements. Terms

davids

Junior Member
I have been having problems with my engine since I have put it in. At a constant speed the vehicle builds up an exhaust sound that sounds like the combution is bad. It feels like it is holding the car back. I did a vacuum test and it kept a perfect reading of 19 at idle. However when I jabed the throttle quick the vacuum reading drop to 0 and then bounced to 23 then back to the normal 19. I have checked the timing and it is right on. I knew with the ls/vtec that I was going to need to up grade my fuel system so I put a larger fuel pump and injectors in. This did not solve the promblem. The first test run I had with the new injectors was great, there was alot more power and accelerated great. It felt like it ran much smother and there was alot more fuel. But then after the first run it started to do the same thing. It feels like the car is taking more air then fuel. But I know that there is more then enought fuel because I put in 300cc injectors and is currently on the stock 45 psi of the b16 system. This should make the system run very rich. Would back pressure play a big part in this. I have a hole in my exhaust at the back that might be a little of the problem but not all of it. So my big problem is that you can not stay at a constant speed. The problem goes away if you accelerate or decelorate.
 

davids

Junior Member
I also forgot to say that the engine runs nice and smooth with my stock Pr4 ls computer. I am using a PR3 ecu.
 

pills_PMD

New Member
VIP
what is the voltage on your TPS?? is the car kind of jerking when you accel or decel?
 

davids

Junior Member
No it does not jerk. When you are going at a constant speed you can feel it build up and it feels like it is holding you back until you accelerated or decelerate. It is really weird.
 
Top