SI CRX

We may earn a small commission from affiliate links and paid advertisements. Terms

I own a 1990 CRX DX converted to mpfi. Someone broke into the driver side and it got wet before I could put in a new window. The key switch and all electrical work but it won't turn over unless I jump the starter out. It runs fine and throws no codes. The clutch switch is good and I also replaced the starter relay and all of the fuses are good. The dash lights come on like they should but don't cut out like they should as you try to crank it- they only flicker. Could it be the main reply or something else? Could some pm me asap w/ some suggestions because this is my daily driver and my fiance needs her car also to get to work. thx
 
Originally posted by honda_79@Aug 24 2005, 02:01 PM
I own a 1990 CRX DX converted to mpfi. Someone broke into the driver side and it got wet before I could put in a new window. The key switch and all electrical work but it won't turn over unless I jump the starter out. It runs fine and throws no codes. The clutch switch is good and I also replaced the starter relay and all of the fuses are good. The dash lights come on like they should but don't cut out like they should as you try to crank it- they only flicker. Could it be the main reply or something else? Could some pm me asap w/ some suggestions because this is my daily driver and my fiance needs her car also to get to work. thx
[post=544653]Quoted post[/post]​



Sounds like a starter relay... Would double check that, make sure you hooked up the new one correctly.. Reconnected the ground, etc.. Also, check the wires for connectivity. Have someone crank it while you check for a signal to the relay. If no signal, I suppose you will have to check the ignition switch and main relay.
 
Originally posted by phyregod+Aug 24 2005, 02:10 PM-->
@Aug 24 2005, 02:01 PM
I own a 1990 CRX DX converted to mpfi. Someone broke into the driver side and it got wet before I could put in a new window. The key switch and all electrical work but it won't turn over unless I jump the starter out. It runs fine and throws no codes. The clutch switch is good and I also replaced the starter relay and all of the fuses are good. The dash lights come on like they should but don't cut out like they should as you try to crank it- they only flicker. Could it be the main reply or something else? Could some pm me asap w/ some suggestions because this is my daily driver and my fiance needs her car also to get to work. thx
[post=544653]Quoted post[/post]​



Sounds like a starter relay... Would double check that, make sure you hooked up the new one correctly.. Reconnected the ground, etc.. Also, check the wires for connectivity. Have someone crank it while you check for a signal to the relay. If no signal, I suppose you will have to check the ignition switch and main relay.
[post=544661]Quoted post[/post]​



the relay is hooked up correctly would the main relay make it do this particular problem? all of my grounds show continuity. i just swapped the main relay out and still the same thing. i have a complete running parts car that im getting my parts off of so i know that they are good, i made sure and checked the parts on the old one b-4 i put them on my car. if it helps i can hear the starter relay clicking everytime i try to start it with the key switch so what would anyone recomend to check next?
 
check for power at the starter solenoid when someone hits the key to the start position, if no power then it could be a bad ignition switch. if there is power then its a bad solenoid
 
Top