Two questions about my H22 Lude

reikoshea

HS Troll...And Mod
Moderator
VIP
Hey guys, i know this should probably go in the swap section, but they dont get as many hits, and they seem to be fairly simple problems.

First my H22 is idling at 2200 RPMs. It was at 2800 until i turned the idle screw on the throttle body as tight as it would go. I dunno what would be causing that problem...i changed ECUs and the engine runs great it just idles REALLY high.

The next problem is that my temp sensor reads red on my car EVERY TIME i drive it. I know for a fact it isnt over heating, but i wont know if it does overheat if that thing reads rong. Sometimes when i turn off the engine and turn it back on it reads right, but then goes straight back up to red line. When i open the hood the engine is not over heating, i can hold both hoses (hot, but not boiling hot). I dunno if i wired something wrong or what, but those probs are scaring me.
 

reikoshea

HS Troll...And Mod
Moderator
VIP
Well i just used an infared thermometer on my engine head and it read 209...the guy at Vandergriff honda said the engine should be between 190 and 230 (guess i fit on that one). He said the problem sounds like the ECT is going out since my fans still come on when they are needed.

The idle thing is bugging me, and i doubt that the lack of a knock sensor is the reason for it, but im gonna go junk yard hunting next week to see if i can find a knock sensor on one of the junkers (planning on a LONG day).
 

22sleeper

Junior Member
i agree i dont think its the knock sensor. is your throttle cable ajusted correctly. and all vacum hoses were they are supposed to be.
 
Top