vtec problem please help

We may earn a small commission from affiliate links and paid advertisements. Terms

first off i will tell you what i have 93 civic dx with a b16a2 swap out of a 2000 si
exedy lightwaight flywheel and stage 2 clutch kit
dc sports header megan racing exaust 2.5 stainless mandrell bent
aem hybred cold air intake
hasport dx to vtec wiring harness
age computer p28 sais skunk 2 dohc 4800 vtec 8500 rev limit
was told by wrecking yard moter and trans hade 40k on it

sometimes when i take it into vtec it will stay in and sometimes it kicks out about 6300 to 6500 and pops a code 21
i have ckanged the presure switch (i think the one that is green and hase the two prong plug) same thing
added more ground wires checked all connections at computer and engine

any help will be greatly apreshated

sorry i cant spell wouth a crap
Nick
 
I had vtec problem with my ls/vtec as well, but got it fixed. In your case, you might want to check the vtec wires. It's kind of weird how your vtec kick off after it's already kick in, but you might want to try not hooking up the ground wire on the green plug. I don't know much, but i think code 21 is Vtec malfunction. So, either you wired it wrong or short circuit. Also, check your soleniod. Maybe there's something wrong with your soleniod, but let's hope i'm wrong.
 
my VTAK did that too, it was becuz the VTEC wire was exposed a little tiny bit (small slice) and it was tapping the ground and caused it to cut in and out.
Trace teh wire to make sure it's not grounding out at all.
 
i had one of those probs in the shop i work.....double check everything
mayb the computer in not good or the wiring is faulty
in the shop we pulled off the valve cover and rev the motor and the vtec was working u could c the cam move it turns out the kid was a idiot he jus couldn't tell when the vtec kicked in...lol.....however we ran into these kinds or prob b4
u could check the resistance of the soleniod we ran into a lot of wiring that went wrong if u have a extra ecu plug it on a c what happens trouble shoot the fcuker
 
i dont know some ti9mes it will hold all day sometimes it wont i am going to try to clean out the vtec soloniod this afternoon for the 2nd time
if it was jumping spark would that cause it cause i have the shitty apc plug wires and the do not fit worth a shit??
 
Originally posted by 93vicb16a2@Aug 21 2005, 11:44 AM
i dont know some ti9mes it will hold all day sometimes it wont i am going to try to clean out the vtec soloniod this afternoon for the 2nd time
if it was jumping spark would that cause it cause i have the shitty apc plug wires and the do not fit worth a shit??
[post=543107]Quoted post[/post]​

if u suspect the wiring or a short jus wet the wires and go 4 a drive...if it fcuks up
more than usual then u know its a short jumping 2 ground
 
check you Vtec Solenoid make sure its not cloged up, also check your oil, maybe your low, but id deff sand down the ground becuz theres no reason it should kick in then die, maybe the ground wire is bad.. what i do it connect it to the 10mm bolt right but the oil switch.. another thing you might wanna do is see if your Ecu is chipped i know alot of people like to have there vtec setup like that. they hit vtec around 5500 and cut it off around 7500 just for that extra getup the vtec gives then all motor from there...
 
Try this, start your car and go down the road, run the car till you hit VTEC in first, second, and third gear: when this is done, keep going into fourth gear and see if it will do what you are saying that it is doing!? If it does it, your VTEC sensor is bad. That is how we used to check them at the Honda dealership i used to work at. And the messed up thing is that it will reset itself after the car is shut off, but for some reason it takes hitting VTEC 3 times to throw a CEL.
 
Originally posted by becoming@Aug 29 2005, 12:56 AM
Try this, start your car and go down the road, run the car till you hit VTEC in first, second, and third gear: when this is done, keep going into fourth gear and see if it will do what you are saying that it is doing!? If it does it, your VTEC sensor is bad. That is how we used to check them at the Honda dealership i used to work at. And the messed up thing is that it will reset itself after the car is shut off, but for some reason it takes hitting VTEC 3 times to throw a CEL.
[post=546463]Quoted post[/post]​


which sensor would that be? i wasnt aware that vtec operation relied on only one sensor.....
 
Low oil pressure could also be a problem.

I know in my gf prelude that when I'm raggin on it and I'm in VTEC in a high G turn, it will sometimes drop out of VTEC because it can't scavage enough oil therefore the pressure drops. Reason is that it drinks about a quart of oil evey 3000 miles. Poor ring seal from the frist owners that didn't drive the car hard enough when it was new.

Just a thought.
 
most time vtec kicks out in first geat or when i shift to second
then i kill the car and re start it and it works for i mabe 2 times
if i dont take it past 6000 it normaly stayn kicked in
was i susposed it use some d series sensor when i did the swap cause i used all bseries sensors (excpt vss) and d series wiring harnes
 
how would i tell if it was oil pressure problem
could it be the vtec oil pressure sensor?


code 21 VTEC Solenoid Valve
so thats where i would look...

if you are sure on your wiring, and nothing is grounding or ungrounding itself then replace it...
 
make sure you don't have any dents in your oilpan.
I had a few and vtec would stop working after driving for a short time.
 
Top