Wierd e brake problem

cheese9988

Senior Member
VIP
I'm trying to get my emergency brake working so I can take it in to get it inspected. I seems so somewhat work, just doesn't lock the drums in the back. I pull up on the handle and it is tight as can be. I tried tightning the adjustor, just make the handle tighter. The arms seem to push the pads out, they tighted up when I pull the brake, and the rear brakes do work normally. Anybody have any suggestions on this?
 

Estorvito

Soy Boricua
Originally posted by cheese9988@May 22 2005, 05:46 PM
I'm trying to get my emergency brake working so I can take it in to get it inspected. I seems so somewhat work, just doesn't lock the drums in the back. I pull up on the handle and it is tight as can be. I tried tightning the adjustor, just make the handle tighter. The arms seem to push the pads out, they tighted up when I pull the brake, and the rear brakes do work normally. Anybody have any suggestions on this?
[post=502299]Quoted post[/post]​

Im having the same problem on my 90 hatch......
I'll be checking that tomorrow, so i'll let you know, "if i get it fixed" --> what the problem is.....
 

VTECPOWER

Senior Member
Could it be something like stretched ebrake cables? That is what happened on one of my friends probe, but that's a ford..... and a whole nother story.
 

Estorvito

Soy Boricua
Originally posted by VTECPOWER@May 22 2005, 08:51 PM
Could it be something like stretched ebrake cables? That is what happened on one of my friends probe, but that's a ford..... and a whole nother story.
[post=502342]Quoted post[/post]​



I dont know.....I think its more like something shot inside the drum itself....
who know, it might be the cable...I dunno...But Like I said..I'll find out tomorrow....
I'll let you know cheesy.....Ohh and i see you are from alden NY..cool....
 

E_SolSi

Member of the 20 nut club
Moderator
VIP
probly need to adjust the brakes
inside there is an adjuster you turn that till there is slight drag on the drum (with the wheel on it should spin about 1.5 - 2 rotations when you spin the wheel)
 

K2e2vin

Senior Member
Originally posted by E_SolSi@May 22 2005, 10:22 PM
probly need to adjust the brakes
inside there is an adjuster you turn that till there is slight drag on the drum (with the wheel on it should spin about 1.5 - 2 rotations when you spin the wheel)
[post=502392]Quoted post[/post]​


that's what i had to do with my CRX drums(but i had to rotate it way more then that).
 

E_SolSi

Member of the 20 nut club
Moderator
VIP
yeah the adjuster will probly have to be turned far more than 1.5-2 times
what im saying is you want enough drag on te drum so that with the wheel on it will only free spin about 1.5 - 2 rotations
 

xj0hnx

I wanna be sedated
VIP
just doesn't lock the drums in the back.


When you're rolling, or when it's in the air? Mine don't lock on the ground, don't want them to. They test perfect on a roller though.
 

cheese9988

Senior Member
VIP
Originally posted by 92b16vx@May 25 2005, 12:48 AM
just doesn't lock the drums in the back.


When you're rolling, or when it's in the air? Mine don't lock on the ground, don't want them to. They test perfect on a roller though.
[post=503252]Quoted post[/post]​


They don't do anything really, don't slow down the car, and don't stop the wheels from turning when the car is on jacks.
 

Estorvito

Soy Boricua
Originally posted by cheese9988@May 22 2005, 05:46 PM
I'm trying to get my emergency brake working so I can take it in to get it inspected. I seems so somewhat work, just doesn't lock the drums in the back. I pull up on the handle and it is tight as can be. I tried tightning the adjustor, just make the handle tighter. The arms seem to push the pads out, they tighted up when I pull the brake, and the rear brakes do work normally. Anybody have any suggestions on this?
[post=502299]Quoted post[/post]​


I just found out my rear brakes were shot.....the drum looked like someone took a bite out of it and the shoes were ----> WELL.....They didnt even look like breake shoes no more..lol.... They had no meat on them and i think that why my e brake wasnt working....ahit i dont even know if my rear brakes were working at all...lol....
anyways I decided to do a rear disk conversion and so far its coming along preetyyyy damn good.....all I need now its the prop. valve cause i cant find mines....

anyways..did you check your brakes shoes and drum, they might need to be replaced...

Good Luck!
 
Top