1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1996 Civic radiator fan issues

Discussion in 'Civic and del Sol - EG and EK' started by Mr123, Sep 9, 2010.

  1. Mr123

    Mr123 New Member

    Likes Received:
    Sep 9, 2010
    So my radiator went recently so I replaced it yesterday and then when I went to make sure everything was fine i noticed that the cooling fan did not come on. I tested the fan by hooking it up to 12v and it worked fine so i know the motor is good and i checked all the fuses and relays. I replaced the ECT sensor and the fan switch but still nothing happens. My AC fan goes on fine but my cooling fan will not turn on unless i close the circuit my self either through the fan switch or relay. What could be the issue?

    Also im not sure if this is the right place to post this.

    Thanks for your help.
  2. Pizzo

    Pizzo New Member

    Likes Received:
    Sep 2, 2010
    Your not low on antifreeze are you? ECT sensor??? sorry normally People will call it the water temp sensor or the water temp for the cooling fan is that what your talking about..

    If your low or have a air pocket the sensor might not be under the fluid the sensor don't read air temp only water temp.. Plus if the engine don't get to the point of over heating to trigger the fan to come on then its not going too.. Have you checked the relay yet?
    if that is good temp sensor is good I can't think of anything else other then the sensor that you replaced is junk. The ECM reads the temp sensor then the ecm sends a signal to the fan relay.. If you have a data scanner you can read the temp of the coolant if it reads 100 degrees and your car has been sitting all night and the outside air temp is 60 degrees then the sensor is bad or wiring at the sensor...
    Hope that helps
Draft saved Draft deleted

Share This Page