1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

91 2.1/2.0 ECU/throttle body issue

Discussion in 'Prelude' started by brokenprelude420, Jun 4, 2008.

  1. brokenprelude420

    brokenprelude420 New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jun 4, 2008
    I have a 91 4WS with a B20A5 swapped into it (the guy before me did it and didn't do it right). He kept the B21A1 ECU, throttle body, intake manifold, and more. I believe I have a throttle position sensor issue due to the 7 LED blinks on the ECU (tried putting in another TB from a salvage yard and still the code 7) and now I noticed (which could have been there before and not noticed it) it is displaying a second code with 1 long blink and 7 short blinks. Would that be a code 17 rather than it displaying 17 short blinks? Code 17 is the vehicle speed sensor, if it is a code 17, what symptoms would that typically cause? Currently the problem I am having is I am losing most of my throttle power above 2000 RPM where it just bogs down when I hit the gas. This is really only an issue after about 15 mins of running. I appreciate all the help!
     
  2. brokenprelude420

    brokenprelude420 New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jun 4, 2008
    Ok, well, after pulling the clock fuse for the 50th time, it is back to just the seven LED blinks. How common is it for multiple throttle bodies to have TPS problems? I don't have the money right now to spend $400 on a new throttle body.
     
  3. awptickes

    awptickes unimpressed by you VIP

    Messages:
    9,272
    Likes Received:
    497
    Joined:
    Aug 29, 2007
    Location:
    MD
    If he screwed one thing up, he probably screwed another up too.


    Check all the wiring. Backprobe all the connectors from the engine to the ECU.
     
Verification:
Draft saved Draft deleted

Share This Page