1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

94 civic idle problem

Discussion in 'General Tech and Maintenance' started by 94civic25, Jul 19, 2006.

  1. 94civic25

    94civic25 Junior Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Jul 19, 2006
    i have a 94 honda civic EX that when in neutral the rpm gauge will jump from 1000 to 3000 repeatedly and wont stop, also when the car is in gear and i stop for a red light or whatever the car will surge and pulse. i have gotten numerous diagnosis for this problem, but none have worked, i have checked my MAP sensor, oxygen sensor, i have cleaned my idle control valve to no avail, this problem is seriously pissing me off and im really frustrated that no one can determine the problem, any suggestions would be much appreciated
     
  2. reckedracing

    reckedracing TTIWWOP VIP

    Messages:
    21,056
    Likes Received:
    1,180
    Joined:
    Dec 5, 2002
    Location:
    NY
    have you tried cleaning and tightening the FITV
    fast idle thermo valve
    on the bottom of the throttle body, three bolts, and i think 2 coolant lines

    open the side with the screws and tighten down the slotted end

    are you sure your coolant is full?
     
  3. 94civic25

    94civic25 Junior Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Jul 19, 2006
    im not really a very experienced mechanic, is there a way to take the FITV off without dissassembling the the throttle body or manifold
     
  4. 94civic25

    94civic25 Junior Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Jul 19, 2006
    well shit, i took the FITV apart and found that the spring was jammed, so i fixed it, and the surging while in gear went away, now all i need is to know what to do to fix that problem while its in neutral
     
  5. reckedracing

    reckedracing TTIWWOP VIP

    Messages:
    21,056
    Likes Received:
    1,180
    Joined:
    Dec 5, 2002
    Location:
    NY
    again... is your coolant full?
    does it bounces when the car is cold or hot?
    did you clean your IACV? idle air control valve?
    tkae off your intake tube and plug the holes lining your throttle body one by one and see which one makes the bounce stop...

    do you have a check engine light?

    did you remove the whole throttle body? if so did you replace the gasket?
     
  6. 94civic25

    94civic25 Junior Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Jul 19, 2006
    i checked the coolant and it was full, the idle is erradic in both temps, i took the IACV off and cleaned it, i didnt take the throttle body off, but when i plugged the holes like you said the one that made the problem stop was the top one, im still not sure what that means, so hopefully you will know, and can finally put my mind at ease
     
  7. reckedracing

    reckedracing TTIWWOP VIP

    Messages:
    21,056
    Likes Received:
    1,180
    Joined:
    Dec 5, 2002
    Location:
    NY
    and you have no check engine light?

    i believe the top hole goes to the IACV
    how did you clean it? do you have another one you could try on your car to see if it works? i think they are expensive

    so were you able to tighten the FITV down?

    unplug your IACV and tell me what happens
     
    Last edited: Jul 25, 2006
  8. 94civic25

    94civic25 Junior Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Jul 19, 2006
    my check engine light has never come unless i unplug the IACV while the car is running, i cleaned the IACV by just completey taking everything apart on it it and cleaning each piece with a rag to get all the dirt off it, i dont have an extra one to put on.

    when i unplugged the IACV, the rpm gauge shot up to 3000 and stayed there

    also the problem with the FITV has come back but it only does it when the temp outside is hot
     
  9. mcboost

    mcboost New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Nov 10, 2013
    I had that problem. Check the pcv valve and remove the tps censor
     
  10. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,411
    Likes Received:
    148
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    I remember my first beer





    Thread is from 2006
     
  11. SPA Motorsports

    SPA Motorsports New Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Jan 10, 2014
    take all of the sensors off the intake mani and clean them very well with brake clean the the IAC spray some wd40 in it trust me it works awesome then when your done maybe seafoam the intake mani you should be fine after that this is a common honda issue!!
     
Verification:
Draft saved Draft deleted

Share This Page