1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

96 gsr swap ques

Discussion in 'HYBRID -> EG-EK / DC' started by typerhead, Nov 7, 2004.

  1. typerhead

    typerhead Member

    Messages:
    74
    Likes Received:
    0
    Joined:
    Nov 7, 2004
    Location:
    ill
    i recently dropped a jdm gsr motor into my civic. i was curious if the iab sensor had to be wired in? when i start up my car when cold it idles about 1400 then it will go to normal but later when car is hot it will idle fine until i am at a complete stop the idle will drop to about 150-200 rpm and seems like its hard to breathe. sometimes it will idle so low it will die. the ecu i swapped is from japan and not sure what the problem is.
    any feedback would be great
     
  2. Slammed90Lude

    Slammed90Lude Senior Member

    Messages:
    3,733
    Likes Received:
    0
    Joined:
    Jan 13, 2003
    Location:
    milford, PA
    the IAB's don't have to be wired for the car to run-

    the idle problem is more than likely a result of problems at the IACV (EACV)

    if the ECU matches the motor that shouldn't be the problem- I'd check wiring to the IACV first and then swap in a unit that is know to be working properly-
     
  3. projekteg

    projekteg Senior Member

    Messages:
    311
    Likes Received:
    0
    Joined:
    Oct 25, 2004
    what trim civic did you put the swap in? unless it was an ex or si, then you have to rewire your iacv to a 2 wire plug, and this is your idle problem. the iab's have to be wired in to function properly, but won't affect how the car runs without them.
     
  4. typerhead

    typerhead Member

    Messages:
    74
    Likes Received:
    0
    Joined:
    Nov 7, 2004
    Location:
    ill
    my car is a 96 hx this is the 2nd time i put a iacv in? after a while the idle just drops down in idle from 850 to 150 sounds then it sounds like its gasping for air and sometimes it will just die when it drops down in idle does will the iacv do that???
     
  5. projekteg

    projekteg Senior Member

    Messages:
    311
    Likes Received:
    0
    Joined:
    Oct 25, 2004
    no, your iacv wouldn't do that. do you have any cel's? could be dirty injectors, fuel filter, pump going bad, anything really, what have you replaced recently and did it just start doing it or has it done this the whole time you've had the swap?
     
  6. typerhead

    typerhead Member

    Messages:
    74
    Likes Received:
    0
    Joined:
    Nov 7, 2004
    Location:
    ill
    i i wired in a 4 wire o2 sensor instead of the both the cables. after that is has been good but shitty
     
  7. noobvang

    noobvang Senior Member

    Messages:
    382
    Likes Received:
    0
    Joined:
    Apr 30, 2003
    Location:
    Twincities, MN
    Checked your timing yet? I've had a similar problem and this was the cause.

    And one more thing, what year is the motor? OBD I or II?
     
  8. typerhead

    typerhead Member

    Messages:
    74
    Likes Received:
    0
    Joined:
    Nov 7, 2004
    Location:
    ill
    96 obd2 jdm gsr maybe ill check the timing again.
     
  9. typerhead

    typerhead Member

    Messages:
    74
    Likes Received:
    0
    Joined:
    Nov 7, 2004
    Location:
    ill
    is thier any hose diagram for evap canistor and i need iab wire up diagram. does anyone have a link or info on it :worthy:
     
  10. noobvang

    noobvang Senior Member

    Messages:
    382
    Likes Received:
    0
    Joined:
    Apr 30, 2003
    Location:
    Twincities, MN
    Not much hoseing under the engine bay. But if you need a mapping of the vac hoses, look under your hood. There should be a pic of the vac hoses.
     
Verification:
Draft saved Draft deleted

Share This Page