1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

b16a idling and bucking

Discussion in 'General Tech and Maintenance' started by x1xblinkx3x, Sep 3, 2008.

  1. x1xblinkx3x

    x1xblinkx3x New Member

    Messages:
    14
    Likes Received:
    0
    Joined:
    Jul 1, 2008
    ive researched a couple threads on this but nothing seems the exact same problem as im having so....i just bought a b16a from hmotorsonline has 35000 miles on it ran pretty good for a couple days now im gettin a knock sensor code which im not too worried about and it just started idling weird it goes to about 1200 and drops real low almost feels like its gonna cut off but it never does and it feels like its missin until i hit 3000 rps when i first take off i thought about my plug wires could be the bucking but i dunno you guys tell me...thanks
     
  2. Justin66

    Justin66 The Hondaswap Canadian

    Messages:
    1,442
    Likes Received:
    24
    Joined:
    Dec 25, 2007
    Location:
    Peterborough, Ontario
    Alot of people have idle issues with all honda motors, there are like 3 or 4 just on the first page of General Maint. I myself have an idle issue as well, only once its warmed. Make sure you run premium gas for the knock sensor.

    Check your ECU for codes.
    Check all sensors for proper voltage.
    Clean out your idle control valve screen.
    Make sure your air filter is clean.
    Check wires, plugs and distributor/coil/cap.

    Alot of checking...... it could be one of those things, or a series.
     
  3. MJ93Hatchback

    MJ93Hatchback New Member

    Messages:
    240
    Likes Received:
    0
    Joined:
    Mar 4, 2008
    I have had similar issues if you researched my thread, but I would also check your fuel filter, or change your fuel filter. I would check the knock sensor because I got my SiR2 from Hmotors and my knock sensor was broken, so I wouldn't just throw it aside. i would suggest putting a new valve cover gasket set, (vcg, orings, etc.) because I had oil leak into my 4th cylinder, and after I replaced that it stopped that leak, and the guy at Hmotors said he would have replaced that from the get go.
     
  4. x1xblinkx3x

    x1xblinkx3x New Member

    Messages:
    14
    Likes Received:
    0
    Joined:
    Jul 1, 2008
    changed plug wires runs alot better still have idle issue and the only code im gettin is 23 which is knock sensor but it could be broken ill have to check
     
  5. MJ93Hatchback

    MJ93Hatchback New Member

    Messages:
    240
    Likes Received:
    0
    Joined:
    Mar 4, 2008
    I know with mine we prob wouldn't have noticed it but we had to take the wire harness off and when we unplugged the knock sensor it came apart and when we looked at it, it was basically rotten. I would def. give it a check
     
Verification:
Draft saved Draft deleted

Share This Page