1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B18 help

Discussion in 'Civic and del Sol - EG and EK' started by 93civicGSR, Jun 10, 2007.

  1. 93civicGSR

    93civicGSR New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Jun 5, 2007
    I just put a JDM B18C1 in my 93 civic, I'm running the p28 ecu from the D16Z6. I was told that on factory settings it is robbing my B18 of horsepower. I just bought my first honda like 4 months ago and never read much into them before. I dunno if should ship it, if I do which one, or if theres a way to program the ecu myself without a chip. any suggestions?
     
  2. 99sidude

    99sidude Moderator Moderator VIP

    Messages:
    3,707
    Likes Received:
    170
    Joined:
    May 1, 2006
    Location:
    Ohio
    the easiest thing to do would be to get a p72 ecu.
     
  3. boostin4fun

    boostin4fun Boosted ls/vtec ohh yeah!

    Messages:
    861
    Likes Received:
    10
    Joined:
    Jun 22, 2006
    Location:
    Omaha
    I wouldnt even run your car with that ecu, its probably robbing your engine for alot of fuel! Get a p72 that is obd1 and call it good.
     
  4. 93civicGSR

    93civicGSR New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Jun 5, 2007
    Yeah your probably right, thanx guys.
     
  5. 93civicGSR

    93civicGSR New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Jun 5, 2007
    Ok. I put the p72 back in and it bobs at 6500 RPMs and the vtec wont kick in... any ideas?
     
  6. boostin4fun

    boostin4fun Boosted ls/vtec ohh yeah!

    Messages:
    861
    Likes Received:
    10
    Joined:
    Jun 22, 2006
    Location:
    Omaha
    Do you have any check engine lights? If so find out what they are and take care of them, that will probably fix your problem. If you havent all ready add any wires for vtec and the secondary butterflies that you may need.
     
  7. 93civicGSR

    93civicGSR New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Jun 5, 2007
    Ok I got it all hooked up and working but when I drive it at first it runs fine. Then it throws a check engine light and the engine wont pull at all. And I cant find anyone with an OBD1 reader. Any idea what the check engine light might be?
     
  8. dramathaized

    dramathaized New Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Jun 14, 2007
    did you run all your wiring correctly? like knock sensor, vtec wires, o2 wires etc..? i have a 93 civic cx hatchback and i just swapped a b18c1 into my car using the p72 ecu and it runs perfect. You can check the code for the check engine light like normal. Just find the plug under the glove box and plug a wire to it and turn the key on to see how many times the check engine light blinks and it will throw the code.
     
  9. boostin4fun

    boostin4fun Boosted ls/vtec ohh yeah!

    Messages:
    861
    Likes Received:
    10
    Joined:
    Jun 22, 2006
    Location:
    Omaha
    Yup, this is the only way you are going to be able to find out what code you are throwing. Search on here or get a repair manual to find out how many blinks = what code. Good luck.
     
Verification:
Draft saved Draft deleted

Share This Page