1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

b18a1swap problems

Discussion in 'Civic and CRX - EF' started by efcivic4dr, Jan 30, 2008.

  1. efcivic4dr

    efcivic4dr New Member

    Likes Received:
    Apr 22, 2007
    cedar rapids, iowa
    Im having a few issues here. I swapped a b18a1 into my 91 civic sedan lx and now Its throwing codes 1 4 and 6.... 1 is 02 sensor, 4 is crank shaft position and 6 is temp sensor. But the big problem is how its running. It running dangerously lean. The wiring is wired for the b series and for dpfi-mpfi. You give the car gas and it act like it wants to die but it doesnt. The idle is around 1000rpm. But when you try to rev it up, its act like it hits the rev limited at 3000rpm- 3200rpm and wont go any further. The motor also head up extremely fast. Any idea on why this is happening? The timing is dead on, spark to every plug. new cap and rotor. Just need some advice, done a lot of things already and just need to get it going.. thanks

  2. efhondakid

    efhondakid My name is Byron. VIP

    Likes Received:
    Mar 2, 2007
    Akron-Canton, Ohio
    If it is throwing a o2 sensor code and you say it is running lean, (very light tan/white plugs) I would say clean/replace sensor and see what that does for you. Crank pos. is in the dizzy which may have gone bad, double check all your dpfi-mpfi wires make 110% sure they are going to the right place and have good connections. You may have to replace the distributor too. As far as the temp code flush the radiator, new thermostat and new sensor here as well.
Draft saved Draft deleted

Share This Page