1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

b18c mounts with LSD

Discussion in 'HYBRID -> EG-EK / DC' started by truoss, Jan 2, 2004.

  1. truoss

    truoss Senior Member

    Messages:
    206
    Likes Received:
    0
    Joined:
    Jul 21, 2003
    I am attempting to install my b18c in my civic. I just noticed that the rear mount is not lining up with the holes on the block. Is this because of the LSD transmission? All the other mounts are working...all these mounts are from a GSR and are supposed to work. I don't understand this at all.... Please help!!

    Thanks
     
  2. dohch22a4

    dohch22a4 Senior Member

    Messages:
    1,744
    Likes Received:
    0
    Joined:
    Feb 5, 2003
    Location:
    Spokane, WA
    No, it's not b/c of the LSD tranny. Is your Civic an EK? If so, I'm pretty sure the rear mount must be from a 99-00 Si.
     
  3. lude68

    lude68 Senior Member

    Messages:
    632
    Likes Received:
    0
    Joined:
    Nov 25, 2002
    ok...what yr civic? what obd is it? and yes...the mounts are suppose to bolt straight up
     
  4. truoss

    truoss Senior Member

    Messages:
    206
    Likes Received:
    0
    Joined:
    Jul 21, 2003
    sorry...I didn't give all the info. It is an 0bd1 gsr going into a 94 civic hatch. I thought I could use all GSR mounts??? The GSR rear mount fits to the frame just fine...it just doesn't fit to the engine! Holes don't line up. The holes on the engine are further apart than on the mount.
     
  5. dohch22a4

    dohch22a4 Senior Member

    Messages:
    1,744
    Likes Received:
    0
    Joined:
    Feb 5, 2003
    Location:
    Spokane, WA
    The mounts should slide in like Michael Jackson slides into little boys. I think somebody either screwed you and gave you the wrong mounts or you need to try harder.
     
  6. dwnthehatch

    dwnthehatch Member

    Messages:
    48
    Likes Received:
    0
    Joined:
    Aug 24, 2003
    I had no problem with mine.
     
  7. truoss

    truoss Senior Member

    Messages:
    206
    Likes Received:
    0
    Joined:
    Jul 21, 2003
    The guy must have just sent me the wrong rear mount. The holes are clearly too close together on the mount. He also sent me the wrong lower drivers side mount...it doesn't line up at all! I wonder which mounts he sent me....they don't look like my CX mounts either. Anyway, thanks for the help guys.
     
  8. xj0hnx

    xj0hnx I wanna be sedated VIP

    Messages:
    14,172
    Likes Received:
    48
    Joined:
    Nov 10, 2002
    Location:
    C.C.TX.
    You need a 94+ integra rear mount.
     
Verification:
Draft saved Draft deleted

Share This Page