1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B20 help..

Discussion in 'HYBRID -> ED-EF / DA' started by B20EFSi, Sep 11, 2009.

  1. B20EFSi

    B20EFSi New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Aug 25, 2009
    Location:
    ohio
    gotta 89 si hatch with a B20b in it straight from tiger it ran fine for 2 days then it just died. the resistor box for the injectors came unplugged due to the clip being broke. then it ran good for another day then sittin at a light i just died. so i thought fuel pump so i replaced it with a stock pump plenty of fuel pressure good strong spark but will not start any idea's??? def need the help its my dd,
     
  2. B20EFSi

    B20EFSi New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Aug 25, 2009
    Location:
    ohio
    no help at all?? :confused:
     
  3. D16SiHatch

    D16SiHatch New Member

    Messages:
    1,297
    Likes Received:
    44
    Joined:
    Sep 7, 2007
    main fuel relay?

    do you hear the relay click on for 2 seconds and then back off, when you turn the key to run. during this period of time you should also hear the fuel pump prime for 2 seconds.
     
  4. bori1974

    bori1974 New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Sep 13, 2009
    Location:
    tamarac, fl.
    I'am thinkin main relay or clog fuel filter
     
  5. INJEN78

    INJEN78 HS LEGEND

    Messages:
    9,187
    Likes Received:
    121
    Joined:
    Oct 1, 2007
    Location:
    OHIO
    check compression..b20's have weak sleeves from the start..also check all your grounds..
     
  6. geedog66

    geedog66 New Member

    Messages:
    17
    Likes Received:
    1
    Joined:
    Aug 25, 2007
    if you still have the check engine light in the dash it should turn on then back off... if it doesnt id try another ecu
     
Verification:
Draft saved Draft deleted

Share This Page