1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

b20 problem

Discussion in 'Civic and del Sol - EG and EK' started by eghatchb20, Jul 3, 2012.

  1. eghatchb20

    eghatchb20 New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Apr 4, 2012
    so i bought a b20 long block and put gsr trans and my car starts but dies as i give it gas and am running a p28(not chipped) and i also put new spark plugs and wires most likely i did a fuel tune up and change the fuel pump but still dies... any suggestion as which ECU i should run with? i heard to run a p75
     
  2. GmodKid

    GmodKid New Member

    Messages:
    73
    Likes Received:
    2
    Joined:
    Nov 7, 2011
    Hello there. It would be preferable to know what chassis the Motor is in. What year motor do you have? Have you checked if you have any cel (check engine lights)? I'm not to sure as to the ecu problem but I do believe you can use the obd1 p75 ecu. If you have a p75 then plug it up. If you have a cel check what it for an go from there.
     
  3. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,413
    Likes Received:
    149
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    I agree with above. It would shock you how many guys come here for help and have a CEL staring them in the face.

    P75 is much better. P28 is SOHC and VTEC
     
  4. GmodKid

    GmodKid New Member

    Messages:
    73
    Likes Received:
    2
    Joined:
    Nov 7, 2011
    Get a p75 check the cel codes and get back to us. We'll be here to help!
     
  5. eghatchb20

    eghatchb20 New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Apr 4, 2012
    thanks and is on a eg hatch
     
Verification:
Draft saved Draft deleted

Share This Page