1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Car is boosting outta control!!!

Discussion in 'Forced Induction' started by Turbo&Auto, Apr 20, 2006.

  1. Turbo&Auto

    Turbo&Auto Nick Go FAST!!

    Messages:
    3,269
    Likes Received:
    29
    Joined:
    Jan 9, 2006
    Location:
    East Burg, PA!
    I got my 92 Accord running now with my turbo setup. I started driving it a bit today and when I went to boost, it spiked right up to 20psi! I immediately let off!

    I checked all my vacuum connections and even put some RTV around the nipple on the Wastegate Actuator. Still went to boost real high. I let off at 14 that time.

    My friend with the Turbo Colt said the wastegate acutator is bad, and stuck. Does that sound right? Is there anything else I can try first?

    Any help is greatly appreciated. I want to drive this thing :)
     
  2. Turbo&Auto

    Turbo&Auto Nick Go FAST!!

    Messages:
    3,269
    Likes Received:
    29
    Joined:
    Jan 9, 2006
    Location:
    East Burg, PA!
    I should add that its a manifold off of a DSM with a EVO3 turbo and internal wastegate.
     
  3. VTECPOWER

    VTECPOWER Senior Member

    Messages:
    1,683
    Likes Received:
    0
    Joined:
    Oct 6, 2003
    Location:
    Winchester, VA
    I would assume that's what's wrong, i mean, that's the only other thing that controls the boost.
     
  4. Turbo&Auto

    Turbo&Auto Nick Go FAST!!

    Messages:
    3,269
    Likes Received:
    29
    Joined:
    Jan 9, 2006
    Location:
    East Burg, PA!
    Damn, no boost for me :cry2: or wait, too much boost for me :cry2:
     
  5. Cashizslick

    Cashizslick !i!i!i!i!i!i!i!i!i!i!i!

    Messages:
    5,751
    Likes Received:
    37
    Joined:
    Aug 15, 2003
    Replace the actuator spring or get a new turbo.
     
  6. Turbo&Auto

    Turbo&Auto Nick Go FAST!!

    Messages:
    3,269
    Likes Received:
    29
    Joined:
    Jan 9, 2006
    Location:
    East Burg, PA!
    new turbo!? For a stuck actuator?
     
  7. Cashizslick

    Cashizslick !i!i!i!i!i!i!i!i!i!i!i!

    Messages:
    5,751
    Likes Received:
    37
    Joined:
    Aug 15, 2003
    The key word in my last post was or.

    What kind of turbo is it that you have? If its a t25 or 14b then you may actually have a vac line problem with ur boost meter resulting in inacurate readings. T25 stock actuators cant handle more than 12 lbs effectively (on the stock spring that is).
     
  8. Turbo&Auto

    Turbo&Auto Nick Go FAST!!

    Messages:
    3,269
    Likes Received:
    29
    Joined:
    Jan 9, 2006
    Location:
    East Burg, PA!
    I found out the problem is the spring, its way too stiff for my project. I'm going to have the flapper welded shut and use a manifold with a external wastegate. Thats the only way I'll see 6-8 psi with this turbo.
     
  9. Cashizslick

    Cashizslick !i!i!i!i!i!i!i!i!i!i!i!

    Messages:
    5,751
    Likes Received:
    37
    Joined:
    Aug 15, 2003
     
  10. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
  11. Turbo&Auto

    Turbo&Auto Nick Go FAST!!

    Messages:
    3,269
    Likes Received:
    29
    Joined:
    Jan 9, 2006
    Location:
    East Burg, PA!
    Thanks 4 the link, prolly end up buying that one :)
     
  12. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    i have no idea if that fits. better call and ask.
     
  13. Turbo&Auto

    Turbo&Auto Nick Go FAST!!

    Messages:
    3,269
    Likes Received:
    29
    Joined:
    Jan 9, 2006
    Location:
    East Burg, PA!
    New wastegate actuator is on the way, will have it Fri. YESSSSSSS!!

    Thanks for the link, worked out well for me.
     
Verification:
Draft saved Draft deleted

Share This Page