1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CEL code 18???

Discussion in 'ECU's, Electronics, and Tuning' started by Flippinjig, Oct 5, 2008.

  1. Flippinjig

    Flippinjig New Member

    Messages:
    46
    Likes Received:
    0
    Joined:
    Aug 28, 2008
    Location:
    In the dog house usually
    I put a D15Z1 in my 95 Del Sol with the ECU and D16Z6 head that came in the car. It fired right up and seems to run good but the CEL is on. I flashed the codes by using a jumper and it has one long flash followed by eight short flashes. I'd say that is 18 but there is not an 18 listed????? I did have a broken wire on the top plug on the passenger fender but I fixed that. What do you guys think?
     
  2. Flippinjig

    Flippinjig New Member

    Messages:
    46
    Likes Received:
    0
    Joined:
    Aug 28, 2008
    Location:
    In the dog house usually
    Any thoughts?
     
  3. eg6sir

    eg6sir Supa Mod Moderator VIP

    Messages:
    21,703
    Likes Received:
    321
    Joined:
    Aug 17, 2005
    Location:
    661 BK CA
    could it be code 10 and code 8?
     
  4. Flippinjig

    Flippinjig New Member

    Messages:
    46
    Likes Received:
    0
    Joined:
    Aug 28, 2008
    Location:
    In the dog house usually
    I guess maybe it could be. It didn't seem to have a pause between the long and short flashes though.
     
  5. Flippinjig

    Flippinjig New Member

    Messages:
    46
    Likes Received:
    0
    Joined:
    Aug 28, 2008
    Location:
    In the dog house usually
    I looked them up:
    8= TDC sensor
    10= Intake air temp
    If these sensors were not working, would the motor still run smooth??
     
  6. eg6sir

    eg6sir Supa Mod Moderator VIP

    Messages:
    21,703
    Likes Received:
    321
    Joined:
    Aug 17, 2005
    Location:
    661 BK CA
  7. Flippinjig

    Flippinjig New Member

    Messages:
    46
    Likes Received:
    0
    Joined:
    Aug 28, 2008
    Location:
    In the dog house usually
    I reseated the plugs, pulled the back up fuse and checked again. This time it flashed one. I reseated the plug again, pulled the back up fuse and No CEL!!! Moral of the story is you have to get it plugged in real good to keep her satisfied.
     
  8. eg6sir

    eg6sir Supa Mod Moderator VIP

    Messages:
    21,703
    Likes Received:
    321
    Joined:
    Aug 17, 2005
    Location:
    661 BK CA
Verification:
Draft saved Draft deleted

Share This Page