1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cooling issues...again

Discussion in 'HYBRID -> EG-EK / DC' started by B18CBeast, Jul 27, 2003.

  1. B18CBeast

    B18CBeast Junior Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Jul 20, 2003
    I have figured out why my car is overheating; the coolant isn't circulating through any of the hoses besides the nearest one from the radiator to the point next to the distributor. Could this be an issue with the pump or maybe the thermostat, a wiring problem? I kind of have to fix it on my own because if I try to drive it to a shop it will overheat. Thanks.
     
  2. 97CTR

    97CTR Senior Member

    Messages:
    745
    Likes Received:
    0
    Joined:
    Jul 10, 2003
    If only your the top hose coming off of the radiator is hot and not the bottom hose then it is your thermostat not letting any flow through.
     
  3. pills_PMD

    pills_PMD Super Moderator

    Messages:
    4,232
    Likes Received:
    0
    Joined:
    Sep 30, 2002
    Location:
    New Albany, OH
    it's most likely the thermostat. that happened to me on my lsvtec swap, then we switched it...
     
  4. JDMilan

    JDMilan Senior Member

    Messages:
    6,730
    Likes Received:
    0
    Joined:
    May 11, 2003
    Location:
    Boca Raton, FL
    you should change out the thermo's with new swaps, they only run like 7 bucks from your local autoparts store.


    Milan
     
  5. B18CBeast

    B18CBeast Junior Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Jul 20, 2003
    thanks you guys are awesome
     
Verification:
Draft saved Draft deleted

Share This Page