1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Couple questions bout my swap

Discussion in 'HYBRID -> ED-EF / DA' started by 91hatchdx, Dec 8, 2006.

  1. 91hatchdx

    91hatchdx New Member

    Likes Received:
    Nov 18, 2006
    ok hi everyone this is my first post here on hondaswap. i have been researching this all day on numerous sites but still can not find the answer. so i swaped in a b18a1 into my 91 dx hatch. It had the d16a6 in there already but the engine took a sh*t and i had to replace it so i thought i might as well upgrade. Found all the work to be pretty simple taking the engine harness off of the d16 and putting it on the b18 the only issue that i am having is that the engine started and ran upon first crank. but after i finished tying up some loose ends, bolting down raditor, installing shift linkage, upgrading grounds to 4gauge, the engine wouldnt start again and the ecu is giving me a code nine. i went through and rechecked all of the wiring that was done due to the mpfi conversion and it is all correct. also when i try to crank the engine you can hear every cylinder fire but the car doesnt start.. I dont know what else to do or check so if anyone has any advice or can help out in any way i would apreciatte it. also if u need any other info just ask and i can let u know.
  2. K2e2vin

    K2e2vin Senior Member

    Likes Received:
    Jan 2, 2003
    Raleigh, NC
    bad CYP sensor? Try swapping distributors.
Draft saved Draft deleted

Share This Page