1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Crazy VSS problem, help please!!

Discussion in 'Engine Building' started by Touge180SX, Oct 2, 2011.

  1. Touge180SX

    Touge180SX New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Feb 16, 2011
    Ok, first here is the setup:

    '99 Integra
    OBD1 LS/VTEC
    OBD1 ECU

    Ok, so I'm throwing a code 17 (VSS) and my speedo and odometer are not working. Here is what I have done so far:

    1. Measured ignition voltage at VSS (GOOD)
    2. With VSS out and hooked to multimeter, measured for pulses when spinning by hand (GOOD)
    3. Measured orange VSS single wire at back of cluster when spinning VSS by hand (GOOD)
    4. Speedo moves when spinning VSS by hand

    Now, here is the weird part; when I put the VSS in the tranny and jack up the front and spin the wheel, nothing! I have tried two different VSS's and two different clusters with the same results. Anyone have any ideas??!?!
     
  2. luky1380

    luky1380 New Member

    Messages:
    78
    Likes Received:
    1
    Joined:
    Jul 13, 2011
    take VSS out put it in gear and ask some1 to spin wheels wile you look in the hole where VSS goes and see if gear which drives VSS spins, if it doesn't you have problem inside trany, if it does than its probably plastic gear on VSS warned out, get OE honda VSS and try it, because some aftermarkets may not work dew to a little different shape/diameter of gear
     
  3. Touge180SX

    Touge180SX New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Feb 16, 2011
    Had the VSS out and spun the wheel and the gear inside the tranny spins. I also tried two different VSS's, what's the chance that both of their gears are bad? :confused:
     
  4. luky1380

    luky1380 New Member

    Messages:
    78
    Likes Received:
    1
    Joined:
    Jul 13, 2011
    if second one is used or aftermarket VSS its very good possibility and i have seen this problem before few times
     
  5. Touge180SX

    Touge180SX New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Feb 16, 2011
    Solved, please delete! :thumbup: Thanks for your help luky!
     
  6. luky1380

    luky1380 New Member

    Messages:
    78
    Likes Received:
    1
    Joined:
    Jul 13, 2011
    why delete???
    let people know what was done and how it worked out because some1 may have same problem and they may fined solution here
     
    Last edited: Oct 8, 2011
  7. Touge180SX

    Touge180SX New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Feb 16, 2011
    Good point. It actually ended up being a bad VSS like you said. The gear must have been just worn enough to cause a problem because they looked exactly the same.
     
  8. luky1380

    luky1380 New Member

    Messages:
    78
    Likes Received:
    1
    Joined:
    Jul 13, 2011
    thats much better, its always good to see another healthy car on the road
     
Verification:
Draft saved Draft deleted

Share This Page