1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CRX-LS Not Holding Power.........

Discussion in 'HYBRID -> ED-EF / DA' started by CReX123, Aug 26, 2004.

  1. CReX123

    CReX123 Senior Member

    Messages:
    477
    Likes Received:
    0
    Joined:
    Jun 3, 2004
    I got my CRX running and i realized i needed a battery cause it wasnt holding power. So i went to autozone and bought a brand new battery, put it in and it wouldnt start right up, so i had to jump it. I jumped it and left it running for a while and turned it off. I went to turn it back on and it wouldnt start back up. My god damn battery isnt holding power. DOES ANYONE KNOW WHAT THE PROBLEM COULD POSSIBLY BE?????
     
  2. 5litereater

    5litereater Junior Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Aug 23, 2004
    Location:
    PA eats lowered cars
    alternator
     
  3. CReX123

    CReX123 Senior Member

    Messages:
    477
    Likes Received:
    0
    Joined:
    Jun 3, 2004
    I have a brand new alternator on the motor, and theres a ground a the main clip that is connected to it. Could there be another part of the wiring harness that isnt connected that could cause the problem????????
     
  4. hcivic.com

    hcivic.com Senior Member

    Messages:
    4,571
    Likes Received:
    2
    Joined:
    Jan 7, 2003
    Location:
    Calgary Alberta canada
    do you own a volt meter?
    test the battery voltage when the car is of it should read 12
    when the car is on iot should read 14.4.
    check that the altinator is pluged in
     
  5. 5litereater

    5litereater Junior Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Aug 23, 2004
    Location:
    PA eats lowered cars
    check that your battery fuse isnt blown. its in the fuse box under the hood.
     
Verification:
Draft saved Draft deleted

Share This Page