1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

d15 problems

Discussion in 'HYBRID -> EG-EK / DC' started by enasnIDX, May 22, 2004.

Thread Status:
Not open for further replies.
  1. enasnIDX

    enasnIDX Junior Member

    Messages:
    14
    Likes Received:
    0
    Joined:
    Dec 1, 2003
    im having problems with my dx. whenever i start it a belt squeals really loud, i think it might be the alternator belt because i have no ac or power steering and until the engine warms up it squeals and revs up and down. if i have any accessories on like heat or rear defrost it sqeals or revs in neutral. im sure i need a new belt or something simple like that. sound accurate?
     
  2. BIGMAN

    BIGMAN Senior Member

    Messages:
    150
    Likes Received:
    0
    Joined:
    Mar 18, 2004
    Location:
    U.K
    when i put in a d15 that had been sitting around for a couple of months i had a nasty squealing when we turned it over turned out the alternator was slightly seized an the belt was slipping round the pulley wheel
    might be an idea just to check when your replacing the belt
     
  3. Jeef

    Jeef NO MA'AM Moderator VIP

    Messages:
    7,150
    Likes Received:
    294
    Joined:
    Sep 29, 2002
    Location:
    CT
    This is not Swap-related. This is the Swap-related forum.

    Try again in the right forum.

    :locked2:
     
Thread Status:
Not open for further replies.

Share This Page