1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

d15b vtec

Discussion in 'Civic and CRX - EF' started by theyangsta, Jul 10, 2009.

  1. theyangsta

    theyangsta New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Apr 25, 2009
    hey guys i finally got that d15b motor into my civic hacth... ok now heres the problem, when iam driving at 60 mph and pressing on the gas it seems to studder like its gonna break down soon??? even at 30 mph it does that, my mec says its the plug wires and spark plugs but i checked them out it seems ok... i dont know what the problem is so any help would do.. thanks and oh i know that this might be a dumb question but did this motor come out of an si,ex,or vx??? i bought it online and dont know what body it came from. any good ideas would help me buyin parts for it
    thanks fellas
     
  2. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    change the fuel filter
     
  3. Ethan

    Ethan Well-Known Member

    Messages:
    2,945
    Likes Received:
    98
    Joined:
    Jun 30, 2008
    x2
     
  4. theyangsta

    theyangsta New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Apr 25, 2009
    hey guys i changed the fuel filter, it worked for a bit but now its like doing the same thing.. could it be the fuel injector?? fuel pump??? anything??and does the exhaust matter??? cuz the cat has been cut off by the mec and weld a freaking pipe on... and now its has been backfiring alot now...dam it everythings going wrong... dam it anything would help guys any good tune ups that i should do???
     
  5. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    well the cat is not the problem, and its always good to get new plugs and wires.are you throwing any check engine codes
     
  6. theyangsta

    theyangsta New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Apr 25, 2009
    the check engine light is on but its obd 1 and the advance auto doesnt have that kind of reader in my town. yea i got new plugs and wires and the fuel filter as well... oh and i still have my stock dx tranny does that matter too?
     
  7. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    no the tranny dont matter, but you need to figure out what codes your throwing. there is a way to count them your self but on a 88-91 car it has to have a wires going to the ecu to jump and count the check lights does yours have that. it will be a blue 2 wire plug next to the ecu area
     
  8. theyangsta

    theyangsta New Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Apr 25, 2009
    hey thanks i found out the problem.... my dumb ass mec put way too much oil into the motor, thats why its like that.. thanks though... oh how am i supposed to check the ecu??? do i need a tool or somthing? or does it have like a little screen display???
     
Verification:
Draft saved Draft deleted

Share This Page