1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

d16y7 swap ignition problems

Discussion in 'General Tech and Maintenance' started by 89y7, Mar 2, 2005.

  1. 89y7

    89y7 Junior Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Mar 2, 2005
    I've just swaped my d16a for a d16y7 but I'm haveing problems getting it started. I've replaced all the wires, plugs, and it's on top dead center but will only sputter. Then I tried 180 out still no good. yesterday when I'd turn the power on a weird clicking noise was coming from under the sterring wheel. What would this have to do with the ignition? I've heard about an ignition relay but I don't know where it would be.Checked every wire and there all in the right place, engine is grounded, fuses in tack. can somebody out there help I would like to see this thing run!
     
  2. Liquidblaze

    Liquidblaze Senior Member

    Messages:
    433
    Likes Received:
    0
    Joined:
    Sep 28, 2002
    Location:
    Huntsville, AL USA
    i have a y7 in my civic but it came with it. i don't know much about electrical but there should be an ignition relay. Get a service manual for electrical problems.

    But are you getting fuel?

    Could it be your timing?

    I think you can check your timing on the crank and cam, pull the plug in cyl 1, put a loooong shafted screw driver down the hole, rotate crank BY HAND until the screw driver rises to its highest point. then pull off your top timing cover and see where that cam is siting, make sure it isnt a tooth off, and while you're at it, check timing belt tension!
     
  3. 89y7

    89y7 Junior Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Mar 2, 2005
    So I've narrowed it down to the main relay. It won't stop buzzing, so I replaced it along with the fuel relay and it still buzzes? This is freaking weird, someone give me a sugestion. Thanx
     
Verification:
Draft saved Draft deleted

Share This Page