1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

D16Z6 Won't start....not a noob.

Discussion in 'Civic and del Sol - EG and EK' started by EGDriver93, Jul 4, 2009.

  1. EGDriver93

    EGDriver93 New Member

    Likes Received:
    Sep 27, 2008
    Engine drives great.....ran all day.......last night tried to start it; it dies after 2 seconds of firing. Ok, main relay?
    1. Replaced Main Relay
    Tried to fire it...no dice. Thought it might be the fuel pump, but you can hear it click on. All electrical works, so the battery is fine. It WANTS to start; starter is brand new, ignition is fine.
    2. Possibly distributor?
    Was told a worn dizzy could be the culprit. No spark from the dizzy to the spark plug, so I'm thinkin this might be it.
    3. Broke the retaining screw that holds the rotor onto the dizzy, so it's going into the shop to drill it out.

    Any thoughts on what you guys might think it might be? Any input is appreciated, Thanks.
  2. serrilion

    serrilion In my own little world! VIP

    Likes Received:
    Aug 13, 2007
    Well I drove my EX to Vermont, parked it... and in the next 5 mins the car just wouldn't start... Went out to the shed, got some testers, replaced spark plugs and still nothing, ripped out my dizzy from a parts car and my car started right up! :) I guess the D series Motors are known for having the Dizzy just die with no warning I would try that :), got a freind that lend u his/ hers to test it out?
Draft saved Draft deleted

Share This Page