1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ECU? ZC wont start

Discussion in 'Civic and CRX - EW' started by CRXSi86, Sep 1, 2007.

  1. CRXSi86

    CRXSi86 Fatty

    Messages:
    168
    Likes Received:
    0
    Joined:
    Jan 5, 2007
    Location:
    Brunswick, OH
    I just finished puutin a JDM Browntop ZC in my 86 CRX Si. Got everything hooked up correctly. went to start it and wont start. it cranks. fuel pump does turn on main relay works fine. i checked fuel pressure and im getting fuel up to the injectors.

    BUT...
    my injectors wont fire. im also getting spark and have comp. my PGM FI light doesnt do the system check and wont go on on my dash. I still have the stock Si ECU but heard it is possible to run on this. can someone please clarify that it does or doesnt. or give some other ideas what else it could be.

    If it helps. we did spray brake clean in the TB to make sure it wasnt anything else. it ran very well for about 5-8 sec. then died. so i know there is no fuel.


    Any help is really appreciated.
    Thanks
     
  2. hondaman321

    hondaman321 hondaman

    Messages:
    8
    Likes Received:
    0
    Joined:
    Jul 6, 2007
    do u have the right injectors? u should be using injectors with a relay box
     
  3. CRXSi86

    CRXSi86 Fatty

    Messages:
    168
    Likes Received:
    0
    Joined:
    Jan 5, 2007
    Location:
    Brunswick, OH
    yeh, i got itr running now, but its running extremely rich,well found out the dizzy is wrong as well as the IM and TB. just a suggestion to everyone, never buy a motor from hmotorsonline.com

    def. got screwed from them in many ways.

    its just about ready to go though
     
Verification:
Draft saved Draft deleted

Share This Page