1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EJ8 ls swap problems

Discussion in 'HYBRID -> EG-EK / DC' started by tgorelik, Jul 20, 2009.

  1. tgorelik

    tgorelik New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    May 25, 2008
    So, after 2 horribly long nights, the engine has finally started. But thats only the good news...It seems to be idling just fine but when I give it some gas its not so quick to crawl up the RPM range as it should be. Also, when I try to drive it, I'll put the throttle all the way down and it doesn't even want to climb past 1,500 or 2K rpms...

    The one thing my friend who did most of the swap for me says is that the dizzy could be misfiring (Im guessing because he had to rig something between a D16Y8 and an LS dizzy to make it fit right.

    Also, both the o2 sensors are disconnected (primary because we can't find the plug coming off the wire harness and the secondary because Im putting a new exhaust one and havent drilled the proper hole for the sensor to go into). Could the sensors also be causing such a lag?
     
  2. nateridesbikes

    nateridesbikes New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Jul 17, 2009
    you cant run a car with no 02 sensors and expect it to run fine. it also could be timing. what exactly did you do to the distributor?
     
  3. tgorelik

    tgorelik New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    May 25, 2008
    I figured so about the sensors just weird how I cant find the primary o2 sensor.

    To be honest man I don't exactly know what he did to the dizzy except that he depinned one harness and spliced it with another one or something (I beleive the one thats on the car is the Y8 dizzy). As for timing, he thought it wasn't timed right but before he did the swap he changed the timing belt, water pump, and tensioner and while doing so noticed the gears weren't right so he turned one of the cams jsut slightly to get it right and left the engine at top dead center before throwing it in.

    The first time the engine turned it backfired so we switched the plugs around and now its running but the weird idling and horrible lag are the problem now...

    Whoever can diagnose/help out I would greatly appreciate it as my car is very vital for my work..
     
  4. nateridesbikes

    nateridesbikes New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Jul 17, 2009
    im no expert but it sounds like your timing is a mess. i messed up the timing on one of my old dsm's and boy did that thing not like to move
     
  5. tgorelik

    tgorelik New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    May 25, 2008
    Damn you're probably right. How would I go about fixing that? My buddy when he came over to install the belt and water pump put the gears to top dead cnter and installed the belt and said everything looked fine...anyways yeah if there's a way I could do it myself please do tell
     
  6. efalex

    efalex New Member

    Messages:
    282
    Likes Received:
    3
    Joined:
    Sep 6, 2008
    Location:
    Danville NH
    you should get a obd2 ls dizzy and check the timing. there is a mark on the cam gearr
     
  7. tgorelik

    tgorelik New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    May 25, 2008
    The thing is my dizzy IS a obd2 since it's off my 98 EX and I beleive what my buddy wanted to do was use the spinning rod of the ex dizzy (or just straight up the whole thing) with ls wires and harness. I'll double chck tomorrow he should be coming over I'll let you know. Thanks so far for the help..
     
  8. efalex

    efalex New Member

    Messages:
    282
    Likes Received:
    3
    Joined:
    Sep 6, 2008
    Location:
    Danville NH
    yea but u need a ls dizzy ur using a single cam one?!
     
  9. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,416
    Likes Received:
    154
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    LS OBD2 dizzy for sure. And after you said the wires were backwards...make me think you should also check where the cam gears are at when the PISTON is at Top Dead Center. Take spark plug out of #1 and place a long skinny screwdriver into the spark plug hole to rest it on the piston. Turn the crank and get the piston up as high as it will go...TDC. Then look at the cam gears and see if the arrows are up and hash marks are horizontal.
     
  10. tgorelik

    tgorelik New Member

    Messages:
    12
    Likes Received:
    0
    Joined:
    May 25, 2008
    I appreciate the replies my baby finally works it was the dizzy afterall. Now I just need to get to the exhaust shop and it'll be complete..
     
Verification:
Draft saved Draft deleted

Share This Page