1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Found Out Whats Wrong...help Now!

Discussion in 'General Tech and Maintenance' started by hatchboy, May 7, 2003.

  1. hatchboy

    hatchboy Sleeves+boost=Love

    Messages:
    312
    Likes Received:
    0
    Joined:
    Nov 27, 2002
    Location:
    Oak Harbor/Battle ground,wa
    Hey i found out whats wrong with my car, basically i have no front or side motor mount, so i am looking for the front tranny mount next to the clutch cable and then side mount next to the battery both are tranny mounts, this is for a 90 civic hatch si 1.6 sohc non vtec
    Any help would be appreciated , i dunno if i busted them becuase i have more power then they can handle or what sense i have a vtec head on the non vtec block that is mildly built. so hmm But finally i found out so someone help me locate some please!!!!!!!!!
     
  2. hatchboy

    hatchboy Sleeves+boost=Love

    Messages:
    312
    Likes Received:
    0
    Joined:
    Nov 27, 2002
    Location:
    Oak Harbor/Battle ground,wa
    bump please!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! :lol:
     
  3. hatchboy

    hatchboy Sleeves+boost=Love

    Messages:
    312
    Likes Received:
    0
    Joined:
    Nov 27, 2002
    Location:
    Oak Harbor/Battle ground,wa
    wtf, come on someone!
     
  4. solblu

    solblu Senior Member

    Messages:
    378
    Likes Received:
    0
    Joined:
    Jan 17, 2003
    Location:
    Ricer
    PM me I've got an extra set of those.
     
  5. MaaseyRacer

    MaaseyRacer Senior Member

    Messages:
    2,980
    Likes Received:
    0
    Joined:
    Sep 29, 2002
    Location:
    San Francisco, Ca.
Verification:
Draft saved Draft deleted

Share This Page